[Solved] NextcloudPi Panel - Unauthorized request. Try reloading the page

I tried to change the ports. Did not go. Then there was the message that this should happen via UPnP. In the router was already UPnP activated.
I have the portforwarding in the router again set to standard (80/443).
Now I have no more access to https: // myinternIP: 4443. That is, I have access to the page, but when I click on the menu items I get: Unauthorized request. Try reloading the page.
Nextcloud itself works. With my phone I have normal functionality.
What do I have to do?

Many Thanks!!

ich habe versucht die Ports zu ändern. Ging nicht. Dann gab es die Meldung, dass dieses über UPnP geschehen soll. Im Router war schon UPnP aktiviert.
Ich habe das Portforwarding im Router wieder auf Standart gestellt (80 / 443).
Nun habe ich keinen Zugriff mehr auf https://myinternIP:4443. D.h., Zugriff auf die Seite habe ich, aber bei Klick auf die Menüpunkte bekomme ich: Unauthorized request. Try reloading the page.
Die Nextcloud an sich funktioniert. Mit meinem Handy habe ich normale Funktionalität.
Was muß ich tun?

Vielen Dank!!

Ups … genau jetzt, mit Absenden dieses Posts, funktioniert es wieder. Vorher seit einer Stunde aber nicht.
Was war denn das?

Ups … exactly now, with submitting this post, it works again. But not for an hour.
What was that?


Whenever something goes wrong and the request from ncp-web fails to deliver the proper CSRF token you will get that message. This is a security mechanism against XSS attacks.

It shouldn’t happen, but I have seen it when doing ‘weird’ things, like refreshing the page during an operation. The workaround in the meantime this gets improved is to open a new tab and it will work ‘authorized’ again.

This is on the list of ncp-web improvements

this was supposed to be in the to-do-list in 2017…
We’re end 2020 and this issue is still here :frowning:
Re-opening the same url in a fresh tab in FF seems to workaround the issue.