[Solved] Nextcloudpi panel port check 80 and 443 mentions "closed" but is open and working

Hello community.

Nextcloud version 14.0.3.0:
Operating system and version _NextCloudPi_11-04-18 v0.66.4 (updated from v0.64.12)

The issue I am facing:

I have correctly port forwarded ports 80 and 443:
Confirmed this by checking with online port checkers and I can also connect to my device from inside and outside home.
The annoying thing is that from Nextcloudpi Panel, at system info , i get the following

port check 80 closed
port check 443 closed

The output of my Nextcloud log in Admin > Logging:

No server logs

Everything is working fine

The output of my config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

if I "cd" into the path I get "Permission Denied"
if I "sudo cd" to the path i get "Command not found"

both commands above are run through ssh (don't know if it has anything to do)

The output of my Apache/nginx/system log in /var/log/____:

in my /var/log/ there is no "Apache" directory. there is an "apache2" directory but with no "nginx" subdirectory in it

As you have probably figured out I am completely new to both nextcloud and raspberry pi, and I just have basic knowledge of linux.

– update –

Don’t know when and how but this morning I checked again and the ports were open. It may have to do with a setting I changed on the DNS section of my ZXHN router