[Solved][nextcloudpi] Add new domain to letsencrypt


I have got a problem with my nextcloudpi.

I tried to use a new domain for my Cloud.

At nextcloudpi-config I changed

  • Noip Domain

So now I have access to the new domain from outside. But with the error “Connection is not secure…” because the certificate is unchanged (still the old domain)

Now my problem, when I try to renew the certificate with letsencrypt at nextcloudpi-config…nothing happens…one time it occurs an error another time it stucks in the installing process.

So I cant change or add a new domain to my certificate.
Is there another way to add it manually?

Or I have to wait 30 days till the certificate will be renewed?

Thanks you a lot!

I don’t use nextcloudpi, but I’m pretty sure you cannot change an already issued certificate.

But you can use a completely new one with more than one CN. Just leave the old one alone and it will expire soon.

What do you use to enroll the certificates? With acme.sh is really simple: you just have to repeat two times (or more) the “-d” option.

Anyway you have to find a way to issue a completely new certificate: there is no way to change the existing one.

1 Like

@radel seems to have a solution here… would you agree to that?

Hi, you have just to run Let’s encrypt again with the new domain and it should just get the new domain. If you can’t you probably need to forward both ports 443 and 80.

I suggest you use the second tab of the wizard, to minimize possible human errors

1 Like