[Solved] Nextcloud works with Desktop Apps, but not with Android and webdav


currently I’m facing issues regarding accessing my nextcloud from Android or WebDav.

I migrated the Installation to a new Server. The new server is “managed” with ISPConfig.

With the webclient I can access everything and create new folders and files. With my Android (Huawei Mate 20 Pro) I’m not able to upload newly created images with the autouploader or create with the app new folders or files. But really strange is that sometimes the upload of images works.

Connecting via Fedora and using webdav has the issue, that I can see the root folders in my profile but not access them. The only error I get is: 207 and 304 with a strange message, that it “permanently moved”.
With the Nextcloud appimage for linux everything works.

My question is now: How can I debug this? I already disabled the dav module on apache.

Thanks for your help and ideas.


after talking to some of my co-workers with more server knowledge than me I can tell, that the problem was a not correct set up ipv6 configuration.
After removing the AAAA Record, everything works like a charm (again).

Hi @RockinMC,

I seem to have the same problem. Can you please provide some more details about how you actually solved the issue? I am not an expert at. Are these settings in the Nextcloud server, on the Android phone or the Fritzbox Router?

Thanks a lot for any assistance!

Hi @nposnie,

I “just” added the IPv6 adress to the vm/linux system.
As I found out, some vps hoster (like ovh) do not initially install the linux with ipv6 enabled.

The setting should be the (linux) server itself. Should be a public and static one.
You mentioned a Fritzbox Router. Perhaps is the solution “just” disable ipv6 support.

All the Best