(Solved) Nextcloud loop after upgrade to Nextcloud 18.0.1

I’ve done a manual upgrade from Nextcloud 18.0.1 rc2 to 18.0.1. the upgrade seemed too run fine and I had the button to return to Nextcloud login. But when I did, the web interface looped, and it keep looping. I don’t know which error files I should look on my server. The error message I have on my browser is :

[Error] The source list for Content Security Policy directive ‘script-src’ contains an invalid source: ‘‘strict-dynamic’’. It will be ignored. (x2)
[Error] Refused to execute a script because its hash, its nonce, or ‘unsafe-inline’ does not appear in the script-src directive of the Content Security Policy. (about:blank, line 0)
[Error] Failed to load resource: Not allowed to authenticate (1, line 0)

The desktop application doesn’t work too.

My server installation :

‪CentOS Linux 7.7.1908 (Core)‬
PHP 7.3.14
Mysql 5.5.64-1.el7
Apache 2.4.6-90.el7.centos

Thank you

I’ve tried with Safari on my Ipad. https://nextcloud.mysite.tls is redirected to https://nextcloud.mysite.tls/apps/files/index.php and I get an error message : file not found.

Problem solved. In fact I use to unzip the nextcloud zip file on my computer and send the files on my server to have immediatly the good onwnership on the,files and folders. But it doesn’t seem to be a good idea since I often forget to send the hidden files :slightly_smiling_face: This is the cause of my problem. Next time I’ll send the zip file on the server and to the unzip and change ownership there.