(SOLVED) Nextcloud and Only Office: Can't access Only Office locally (Error)


I solved it, I had set SSL cipher and TLS settings in my nginx.conf… I deleted them and then it started working!

I’m just setting up OnlyOffice with Nextcloud (on the same vps). My problem is that although the Onlyoffice-server is working (when accessed remotely it says “Document Server is running”),
when I try to connect nextcloud to the only office server (using the nextcloud app) it gives me this error in nextcloud: Error while downloading the document file to be converted.

So I tried if I can access the onlyoffice server locally on my vps, and no: wget on office.xxxx.de:8099 gives me Error 400: Bad Request. What I also tried was setting up a ufw firewall rule for 8099/tcp, that didn’t help.

Does anybody of you know why I can access my Only Office Server externally but not locally (that seems to be the problem here)…??

Thanks in advance!

My configs:

startup command: docker run -i -t -d --restart=always --name ONLYOFFICEDOCKER -p 8099:443 -v /app/onlyoffice/DocumentServer/data:/var/www/onlyoffice/Data onlyoffice/documentserver

nginx config (reverse proxy):

    upstream docservice {

    map $http_host $this_host {
    "" $host;
    default $http_host;

    map $http_x_forwarded_proto $the_scheme {
    default $http_x_forwarded_proto;
    "" $scheme;

    map $http_x_forwarded_host $the_host {
    default $http_x_forwarded_host;
    "" $this_host;

    map $http_upgrade $proxy_connection {
    default upgrade;
    "" close;

    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection $proxy_connection;
    proxy_set_header X-Forwarded-Host $the_host;
    proxy_set_header X-Forwarded-Proto $the_scheme;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

    server {
        server_name office.xxxx.de;

        listen 443 ssl http2; # managed by Certbot
        include /etc/letsencrypt/options-ssl-nginx.conf; # managed by Certbot
        ssl_dhparam /etc/letsencrypt/ssl-dhparams.pem; # managed by Certbot

    location / {
    proxy_pass http://docservice;
    proxy_http_version 1.1;

    add_header X-Content-Type-Options nosniff;

    add_header Strict-Transport-Security "max-age = 31536000; includeSubDomains" always;

    #add_header X-Frame-Options ALLOWALL;

        ssl_certificate /etc/letsencrypt/live/office.xxxx.de-0002/fullchain.pem; # managed by Certbot
        ssl_certificate_key /etc/letsencrypt/live/office.xxxx.de-0002/privkey.pem; # managed by Certbot
    server {
        if ($host = office.xxxx.de) {
            return 301 https://$host$request_uri;
        } # managed by Certbot

        listen 80;
        server_name office.xxxx.de;