[SOLVED] NCP - Cannot Get nc-snapshot-sync & nc-backup-auto to Work

I’m hoping someone can help. I am running NCP on an Odroid HC2. I initially set the Odroid up with a single hard drive connect via the supplied SATA connection on the HC2. Everything is working perfectly and everything is configured just like I want. I am trying to set up a local backup before I go to the next step of off-site backups.

I am using this guide: Link

Since I originally only installed a single hard drive I could not simply connect another drive (via USB) and use nc-format-USB because it would format both drives and I would lose my data. I tried to disconnect my original hard drive and just attach the new drive but when the system booted I could not connect via the WebUi or SSH. Shut down and reconnect original hard drive and the system came back up and functioned normaly. So after some research and Googling last night I got the new hard drive set up as a BTRFS drive. It is mounted to /media/myCloudDriveBackup or /media/USBdrive1. I am able to to run nc-export-ncp and save the resulting tar file to a directory on the new drive but for some reason I cannot get either nc-snapshot-sync or nc-backup-auto to work. Both are set up and as far as I can tell should be working.

Any place I should begin to look to try to find the problem? I am wondering what the permissions need to be for the backup directories on the new drive. Could that be part of the problem?

Any help is greatly appreciated. I am really enjoying NCP but I need to be sure my data is safe!

Well it seems I figured out the fix myself. I’m not sure why this matters but when I changed the directories for backup locations to /media/USBdrive1 instead of where the drive is mounted /media/myCloudDriveBackup it started working. Not sure if that makes sense but nonetheless it is now working.


Thanks for reporting. Glad to hear you got it sorted!

If you labeled your drive myCloudDriveBackup and used nc-automount, it can make sense.

Would you edit/add [SOLVED} to title please?