[Solved] Nc-snapshot-sync - doesn't seem to be working

I am using NCP (v1.24.0) on raspberry pi 4, with 2 external drives. One for data (USBdrive which is mounted on /media/myCloudDrive) and another drive for backup (/media/USBdrive1 mounted on /media/NCPBackup). Things are looking great, expect the regular backup setup.
I have been trying to use nc-snapshot-auto to create the regular snapshots and nc-snapshot-sync to transfer to my backup drive. I can see the regular snapshots are getting created on my main data drive (/media/USBdrive/ncp-snapshots/) but these are not getting sync to my backup drive (/media/USBdrive1/ncp-snapshots/).

I have been searching if others have also faced the same issue but could not find much.

This topic has the same setup but seems to be working in this case.

Any help would be greatly appreciated.

I’d check output of

ls -lh /media/

To see what the (simlink) USBdrive1 is pointing to

When using automount, USBdrive and USBdrive1 can be switched around, after a reboot, better to use LABELs to make sure drives are mounted correctly and consistently

You can then ajust path to /media/LABEL/ncp-snapshots/

If it still doesn’t work try running it from terminal with ncp-config.

Thanks for your response. Yeah! I did check that

root@nextcloudpi:~# ls -lh /media/
total 144K
drwxr-xr-x 1 root root 60 May 28 11:17 myCloudDrive
drwxrwxrwx 1 root root 128K Jan 1 1970 NCPBackup
lrwxrwxrwx 1 root root 19 May 30 05:08 USBdrive -> /media/myCloudDrive
lrwxrwxrwx 1 root root 16 May 30 05:08 USBdrive1 -> /media/NCPBackup

When you are saying "running it from the terminal with ncp-config " - Do you mean running nc-snapshot-sync through the terminal? If it’s handy, can you advise how?

In terminal/ssh/putty run

sudo ncp-config

select BACKUPS and select nc-snapshot-sync , using the actual path instead of the sym-link.


Thanks! Setup done.

It says Sync periodicity (in days) 1. Not sure what time this sync starts. Will wait for 24 hrs and update the results.

defaults to 4:30 am afaik
Can check adjust settings in


Yeah! … working now. It seems the issue was when scheduling it from the webpage.

Thank you so much for your help!.

root@nextcloudpi:/media/NCPBackupDrive/ncp-snapshots-bkp# date

Sun 31 May 21:01:40 BST 2020

root@nextcloudpi:/media/NCPBackupDrive/ncp-snapshots-bkp# cat /etc/cron.d/ncp-snapsync-auto

10 21 * * * root /usr/local/bin/btrfs-sync -qd “/media/myCloudDrive/ncp-snapshots/” “/media/NCPBackupDrive/ncp-snapshots-bkp/”

root@nextcloudpi:/media/NCPBackupDrive/ncp-snapshots-bkp# ls -lrt

total 0


You have new mail in /var/mail/root

root@nextcloudpi:/media/NCPBackupDrive/ncp-snapshots-bkp# ls -lrt

total 0

drwxr-x— 1 www-data www-data 246 May 31 21:22 daily_2020-05-28_111708

root@nextcloudpi:/media/NCPBackupDrive/ncp-snapshots-bkp# date

Sun 31 May 21:23:33 BST 2020

root@nextcloudpi:/media/NCPBackupDrive/ncp-snapshots-bkp# ps -ef | grep ncp-snapshots
root 13264 13256 0 21:10 ? 00:00:00 /bin/sh -c /usr/local/bin/btrfs-sync -qd “/media/myCloudDrive/ncp-snapshots/” “/media/NCPBackupDrive/ncp-snapshots-bkp/”
root 13266 13264 0 21:10 ? 00:00:00 /bin/bash /usr/local/bin/btrfs-sync -qd /media/myCloudDrive/ncp-snapshots/ /media/NCPBackupDrive/ncp-snapshots-bkp/
root 13478 13266 0 21:10 ? 00:00:00 /bin/bash /usr/local/bin/btrfs-sync -qd /media/myCloudDrive/ncp-snapshots/ /media/NCPBackupDrive/ncp-snapshots-bkp/
root 13481 13266 0 21:10 ? 00:00:00 /bin/bash /usr/local/bin/btrfs-sync -qd /media/myCloudDrive/ncp-snapshots/ /media/NCPBackupDrive/ncp-snapshots-bkp/
root 13483 13478 0 21:10 ? 00:00:00 sudo btrfs send -q /media/myCloudDrive/ncp-snapshots/daily_2020-05-28_111708
root 13484 13481 0 21:10 ? 00:00:00 sudo btrfs receive /media/NCPBackupDrive/ncp-snapshots-bkp/
root 13485 13481 0 21:10 ? 00:00:00 /bin/bash /usr/local/bin/btrfs-sync -qd /media/myCloudDrive/ncp-snapshots/ /media/NCPBackupDrive/ncp-snapshots-bkp/
root 13495 13484 24 21:10 ? 00:03:07 btrfs receive /media/NCPBackupDrive/ncp-snapshots-bkp/
root 13496 13483 14 21:10 ? 00:01:55 btrfs send -q /media/myCloudDrive/ncp-snapshots/daily_2020-05-28_111708
root 14620 9917 0 21:22 pts/1 00:00:00 grep ncp-snapshots