[SOLVED : Music App causes Webdav errors somehow] AIO (Beta Channel)(Nextcloud 26) Unkown webdav error..i dont know what to do, please help

[webdav] Error: TypeError: OC\Files\Cache\QuerySearchHelper::getCachesAndMountPointsForSearch(): Argument #1 ($root) must be of type OC\Files\Node\Root, OC\Files\Node\LazyRoot given, called in /var/www/html/lib/private/Files/Node/Folder.php on line 237 at <>

  1. /var/www/html/lib/private/Files/Node/Folder.php line 237
    OC\Files\Cache\QuerySearchHelper->getCachesAndMountPointsForSearch([“OC\Files\Node\LazyRoot”], “/bsteimer/files/Money”, false)
  2. /var/www/html/lib/private/Files/Node/Folder.php line 291
    OC\Files\Node\Folder->search([“OC\Files\Search\SearchQuery”])
  3. /var/www/html/custom_apps/music/lib/Utility/Scanner.php line 383
    OC\Files\Node\Folder->searchByMime(“audio”)
  4. /var/www/html/custom_apps/music/lib/Hooks/FileHooks.php line 42
    OCA\Music\Utility\Scanner->deleteFolder([“OC\Files\Node\Folder”])
  5. <>
    OCA\Music\Hooks\FileHooks::deleted([“OC\Files\Node\Folder”])
  6. /var/www/html/lib/private/Hooks/EmitterTrait.php line 105
    call_user_func_array(["OCA\Music\Ho … "], [[“OC\Files\Node\Folder”]])
  7. /var/www/html/lib/private/Hooks/PublicEmitter.php line 40
    OC\Hooks\BasicEmitter->emit(“\OC\Files”, “preDelete”, [[“OC\Files\Node\Folder”]])
  8. /var/www/html/lib/private/Files/Node/Root.php line 143
    OC\Hooks\PublicEmitter->emit(“\OC\Files”, “preDelete”, [[“OC\Files\Node\Folder”]])
  9. <>
    OC\Files\Node\Root->emit(“\OC\Files”, “preDelete”, [[“OC\Files\Node\Folder”]])
  10. /var/www/html/lib/private/Files/Node/LazyFolder.php line 72
    call_user_func_array([[“OC\Files\Node\Root”],“emit”], [“\OC\Files”," … ]])
  11. /var/www/html/lib/private/Files/Node/LazyFolder.php line 100
    OC\Files\Node\LazyFolder->__call(“emit”, [“\OC\Files”," … ]])
  12. /var/www/html/lib/private/Files/Node/HookConnector.php line 145
    OC\Files\Node\LazyFolder->emit(“\OC\Files”, “preDelete”, [[“OC\Files\Node\Folder”]])
  13. /var/www/html/lib/private/legacy/OC_Hook.php line 105
    OC\Files\Node\HookConnector->delete([true,“/Money”])
  14. /var/www/html/lib/private/Files/View.php line 1295
    OC_Hook::emit(“OC_Filesystem”, “delete”, [true,“/Money”])
  15. /var/www/html/lib/private/Files/View.php line 1165
    OC\Files\View->runHooks([“delete”], “/Money”)
  16. /var/www/html/lib/private/Files/View.php line 351
    OC\Files\View->basicOperation(“rmdir”, “/Money”, [“delete”])
  17. /var/www/html/apps/dav/lib/Connector/Sabre/Directory.php line 307
    OC\Files\View->rmdir(“/Money”)
  18. /var/www/html/3rdparty/sabre/dav/lib/DAV/Tree.php line 179
    OCA\DAV\Connector\Sabre\Directory->delete()
  19. /var/www/html/3rdparty/sabre/dav/lib/DAV/CorePlugin.php line 281
    Sabre\DAV\Tree->delete(“files/bsteimer/Money”)
  20. /var/www/html/3rdparty/sabre/event/lib/WildcardEmitterTrait.php line 89
    Sabre\DAV\CorePlugin->httpDelete([“Sabre\HTTP\Request”], [“Sabre\HTTP\Response”])
  21. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 472
    Sabre\DAV\Server->emit(“method:DELETE”, [["Sabre\HTTP\ … ]])
  22. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 253
    Sabre\DAV\Server->invokeMethod([“Sabre\HTTP\Request”], [“Sabre\HTTP\Response”])
  23. /var/www/html/3rdparty/sabre/dav/lib/DAV/Server.php line 321
    Sabre\DAV\Server->start()
  24. /var/www/html/apps/dav/lib/Server.php line 366
    Sabre\DAV\Server->exec()
  25. /var/www/html/apps/dav/appinfo/v2/remote.php line 35
    OCA\DAV\Server->exec()
  26. /var/www/html/remote.php line 172
    require_once(“/var/www/html/a … p”)

DELETE /remote.php/dav/files/bsteimer/Money
from 77.13.128.32 by bsteimer at 2023-06-10T08:24:31+00:00

Hi, can you disable the music app and check if this makes it work?

1 Like

Yes it worked
…im stunned

Thank you so much
…you saved my day …

but why is the music app causing that… was so excited to have my own spotify :frowning:

1 Like

Hi, I’m having the very same issue. However, I would like to use the Music app. Is there anything that can be done to solve this issue and allow the Music app to be enabled?
Thanks for any help you can provide.

Hi @MTNWF, the issue has been solved, it should be included with an upcoming update. In the meantime, depending on how technically versed you are, you may want to apply the quick & dirty fix as described in the Github discussion (link right above your post).

2 Likes