[Solved] Last background job execution ran 8 days ago


I have a problem with the cron job which is not executed successfully.

The [security & setup warnings] result is the following

There are some errors regarding your setup.

Last background job execution ran 8 days ago. Something seems wrong. Check the background job settings

The last entry in the logs is the following

require(): Failed opening required '/home/www/nextcloud/apps/mail/vendor/composer/../rubix/tensor/src/constants.php' (include_path='/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Crypt_Blowfish:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Date:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Exception:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Idna:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Imap_Client:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_ListHeaders:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Mail:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_ManageSieve:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Mime:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Nls:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Secret:/home/www/nextcloud/apps/mail/vendor/pear-pear.horde.org/Horde_Smtp:/home/www/nextcloud/apps/mail/vendor/pe at /home/www/nextcloud/apps/mail/vendor/composer/autoload_real.php#73

I removed the mail app since this last log but problem is still present.

The www-data crontab end with the folowing line

*/5  *  *  *  * php -f /home/www/nextcloud/cron.php

I have no error returned when I try to execute the PHP CRON job manually

myuser@myserver:~$ sudo -u www-data php -f /home/www/nextcloud/cron.php

I have no more idea on something to check or to test.
Could you please help me to solve the issue ?

Many thanks.

Hi @vgr

If you are using APCu as a local memory cache, please read the following thread: Cron not running in NC 21.0.3

1 Like

Solved after adding



For anyone with the same issue with APCu, you can also modify your crontab to ready:

*/5 * * * * php -f /var/www/nextcloud/cron.php --define apc.enable_cli=1