[Solved] iOS App Not Uploading Files

I just installed NC for the first time on a raspberry pi 2. I am very new. I have enabled SSL correctly, and also setup port forwarding correctly. I downloaded the iOS apps for iPad Pro 10.5 and iPhone 6s. I can add folders that will sync across devices, but anytime I upload photos or files from iOS I can not get them to upload. I get “Error The server is temporarily unavailable”. I am using NC 12.0.2 and the current version of the iOS apps. I’m also using no-ip that is correctly setup. I can access from multiple devices outside of my house. I’ve tried uninstalling the apps, and also deleting the accounts on the apps. There must have been something I missed if I get an error when uploading or downloading from the apps themselves. I tried looking to see if a similar post has been written, I didn’t see one, and aplogogize if there is one. I’m about 24 hours into my NextCloud install. More info, I have also increased the max file size to 2000M.

Sorry to post this, but I did manage to resolve the issue on my own. I enabled encryption in the admin settings, but didn’t enable the encryption app. Once I did this, uploads and downloads were working again. Thanks for reading this post anyway, hopefully it will help someone in the future.

I have a similar issue with my IPads.
What exactly do you mean with encryption app ?
Is that an iPad app or a nextcloud app ?

Thanks in advance.

It can be the encryption, but there is another topic with more users having problems: