[Solved] Integrity check failed EXTRA_FILE - lib/private/Memcache/APC.php

Hi there,
after upgrading from nextcloud 11 to the current version 12.0.0 I got the failed integrity message.
Most of the issues I could solve by myself. But now I stuck with one problem.

  • core
      • lib/private/Memcache/APC.php

If I delete APC.php the nextcloud page cannot be displayed anymore. Copying the APC.php back into the folder resolves the problem immediately with the webpage but not with the integrity check.
What can I do to solve this issue?
Thank you for your support!!!

An answer from a different post which might help you as well.

Hello Hollerauer,
Thanks for answering and sorry for my late reply.
I did the upgrade manually. Everything is working fine beside the integrity check with the file APC.php.
If I delete APC.php in the folder lib/private/Memcache/ I get the following on the webside:
"This page isn’t working
xxxxxx.com is currently unable to handle this request.
If I copy the APC.php back everything it’s working again. Beside the integrity check.
What can I do?

Originally I wanted to advice you to go to https://nextcloud.com/changelog and download the file (APC.php) and replace yours with it.
But than I realized that there is no APC.php in the folder you describe ./lib/private/Memcache but a APCu.php file.

Can you compare the content of your APC.php with the APCu.php from NC server repository? If content is equal, replace your APC.php with APCu.php from NC server repository.

Both files, APC.php and APCu.php, are in the folder. I compared the content of both files. They are not equal.
After deleting APC.php temporary I had this error message at the logging section:

“OC\HintException: Memcache \OC\Memcache\APC not available for local cache at /var/www/nextcloud/lib/private/Memcache/Factory.php#96”

Any further idea?

Nope. Not at the moment

Thank you for trying to help me out!
During the weekend I will work more on the issue and if I can somehow resolve the issue I will post it here.

Today I could solve my problem.
To use APCu instead of APC you have to change your config.php.
Add ‘memcache.local’ => ‘\OC\Memcache\APCu’, and the problem is solved. No more integrity check failures!