[solved] Get code integrity error after import a backup from 32bit to 64bit jessie

Dear all,

as one of my nextcloud installation is on a 32bit debian jessie, I thought it would be a good idea to install nextcloud on a 64bit jessie. Therefore I installed a clean 64bit jessie, downloaded nextcloud 10 (as my other server has had same version) installed mysql, created a database with the same db name like in my old nextcloud installation.
Furthermore I activated in the new installation the same apps. After that I backuped the nextcloud directy with rysnc -Aax
and I backuped mysql with the following command:

mysqldump --lock-tables -h localhost -u nextclouduser --password=Password nextcloud > /mnt/backup2/backupnc/nextcloud-sqlbkp-20170107.bak

After that I stopped apache at my new server, copied the datadirectory with rsync -Aax
and try to import sql-data with the command:
mysql -h localhost -u nextclouduser --password=Password nextcloud < /mnt/backup/backupnc/nextcloud-sqlbkp-20170107.bak

Then I tried to access my nextcloud install at the new server, I get the message, that 2 apps have to be updated (calender and task), after the update has finished I was able to log in with my useraccount. There I get the error that I have problems with code integrity and I cannot open my files or upload new files.

I have read in another topic, that the import should be in a new database, therefore I created a new database (called nextcloudnew), import mysql-data, edited my config.php but problem seems to be the same.

Here ist an extract of the result of analyse:

[core] => Array
[EXTRA_FILE] => Array
[nextcloud/themes/README] => Array
[expected] =>
[current] => 902ad902d14772f4030f4e8aaec8707ada9904c7e59913057769a55b694986df3f6aad04ed66fb7175d2dbe89b0ce014b80c3737306b3cb61e87f947c7664ee2

                [nextcloud/themes/example/defaults.php] => Array
                        [expected] => 
                        [current] => cb787b0bab2df166bed820f1cff9541262d4801a9feb82dac992567256b6bfed2eb3ba8d8cbd97673088081049c2e7378c37c57f745ca8f80fe8c8163957559e

There are a lot of files that have this error. I think this is the important part, but I don’t know exactely how I can solve this (and maybe how I could prevent such an error for a next import).

Thanks and best regards

Do you use own themes? If there is an additional file, you can normally delete this file and then re-run the test again (via admin page).

This isn’t an explanation why code-integrity didn’t report it when you were on the previous setup. Perhaps a bug in the 32-bit code of the integrity-checker, other code problem, …?

I don’t have own themes. I just downloaded nextcloud from https://download.nextcloud.com/server/releases/.
I thought maybe the reason could be the change from 32bit to 64bit, therefore I described it in the topic…
Which logs could be interesting in order to find a solution ? Or shall I test to migrate the backup in a 32bit Jessie first ?

I don’t think that you have to migrate into a 32-bit system. Just check your backup if there are any of these additional files. Perhaps from an previous update where you didn’t delete all old code files?

That was the first time, that I did a backup. I just begin for a few month with my first Cloud installation, so I’m not so familiar with mysql, php and apache…
I have had furthermore another error with htaccess. I added an entry for nextcloud directory but nothing happened, I changed the data directory of my nextcloud installation, the error with htaccess disappears, but my problem with code integrity is still there.

I’m not sure whether the problem is because of the code integrity.

I’ll describe further behaviour:
So users and data are imported, but I cannot access to these files. I also cannot create new files. Entries in calender are imported, too and i can create new entries.
I created a new user, that user can create new files, but cannot display photos. The error appears in German, that no preview can be created. I shall change to another picture during the old one will be removed from diashow. “Fehler! Konnte keine Vorschau dieser Datei erzeugen.
Bitte wechsle zum nächsten Bild, während im Hintergrund das Bild aus der Diashop entfernt wird.”

I checked syslog, mysql.err, apache error.log, but I didn’t noticed anything, if I tested it.
Maybe I’ll start nextcloud without memcache configuration. But before I imported my old installation, I used the same config.php from my old installation and nextcloud worked.

Just check your backup if there are any of these additional files.

Which backup shall I check ? Datadirectory whether these files are the same ? Or anything in mysql backup ?

Well,… I think I have solved my problem, but to be honest, I don’t know exactely why this happened…
So, I made a backup like described. For my data directory I have another harddisk that was mounted in /var/www/nextcloud/data2. In the backup, there is also a directory data2 - but it is empty…
I repeated backup with rsync to another directory and the result is the same - the mounted directory data2 is empty.
Now I have made an extra backup of data directoy and have copied the data in my new data directory and now I can open my files and create new ones and after I started a new analysis of code integrity, the message doesn’t appear.

So, it seems that the problem was, that my data directory was empty. I understand that, but I don’t understand why rsync doesn’t copy it… Is the reason because it was mounted ? If yes, maybe there could be hint on the backup howto. I know it is described that you have to backup your data directory and config directory, but in my case I thought, I only need to backup my nextcloud folder as the data directory is in it.

Thanks and best regards

Hi Kamikaze,
Good that you got this solved.
What I am curious about is: did you see any performance increase, going from a 32 to a 64 bit install?

It’s about php, that 32-bit php comes with the upload limit of 2GB. For the performance, you need rather large systems to see a difference (64-bit systems can address more RAM).

Sorry, for my late reply…
I’m not quite sure, whether there could be performance increase. And I don’t recognize the upload limit until yet. I would like to install spreed me with own webrtc. I found some manuals and I tried it on some test mashines. But my first working mashine has been with a 64bit system. I’m not quite sure, whether go is important in 64bit for spreed me. Therefore I would like to upgrade my nextcloud installation to a 64bit jessie.

@kamikaze Spreed WebRTC (Go app) should run fine on 32bit. I haven’t tried it however, so please report whether it works or not :slight_smile:

Unfortunately I have deleted my test mashines where I tried to install spreed with 32 bit. I cannot exactely remember the problems… First I have had a lot of problems to build the webrtc (as a lot of packages couldn’t be found). Then the spreed webrtc doesn’t start… But I can’t remember the error messages… And then I tested it on a 64bit mashines, and I wondered how fix I was able to install it. But well… It could be that the howto was got for 64 bit mashines.