[solved] File Drop option not showing up

I have got a noob question about file dropping. I am on NC 22.2.0 and according to the overview all checks passed.

When I look at the documentation, there is supposed to be an option named “file drop” when I click “Share link +” in the sharing settings of a folder.

However, after having clicked the plus icon next to “Share link” I get a clipboard icon (so far so good) and three dots for options. The options listed only include this:

Share Link ...

Share label
Allow editing
Hide download
Password protect
Video verification
Set expiration date
Note to recipient
Add another link

Is there any configuration option I need to enable first to be able to use file dropping?

Any help would be highly appreciated!

This is the correct screenshot including File drop (upload only)

Do you have an ad blocker? Can you deativate the ad blocker?
Or can you test the access in another browser?

If it is not a browser problem you can test it with a demo account.

Register at https://try.nextcloud.com
You get a username with 16 characters. The password is demo.
You can use this account 60 minutes.

1 Like

Thank you so much for that speedy reply.

On the demo site I can see exactly the same options as in your screenshot. No such luck on my site, though. I tried Firefox and Brave which did not produce any different results. Compared to the screenshot, the three radio buttons at the top are just missing.

Also when hitting F12 in the browser, there seems to be nothing between “Share label” and “Allow editing” (again, I’m a noob, so I have no idea whether this observation is even relevant).

1 Like

Perhaps something can not be loadet. Hit F12 and use Network Analysis. Are there HTTP requests not equal to 200?

1 Like

I just downloaded the latest zip and copied all the files over my current installation. That did not make a difference.

As requested I checked the console. The only 404 I could find was this one:

test is the name of the directory on top of the one I intended to share.

P.S. Tried yet another browser (Vivaldi freshly installed), no difference.

1 Like

Just a quick note to let you know this has been solved.

I do feel rather silly, but as it turns out all I needed to do was to uncheck “allow public upload” and check it again. After that everything just worked.

@devnull , thank you once again for taking the time to help me. I highly appreciated this.

1 Like