[Solved] Fehlerhafte Anzeige nach Installation

Hallo zusammen,
ich bin neu hier.
Ich habe Nextcloud auf einer Subdomain (cloud.MYDOMAIN.de) installiert.
Die Startseite der Installation passte auch noch, alles so wie es sein sollte. Doch nach der Installation erhalte ich (unabhängig vom Browser) folgende Darstellung:

Da muss ja irgendeine Einstellung nicht passen?!
Kann mir jemand weiterhelfen woran es liegen könnte?
Danke im Voraus!!!

da fehlt u.a. css.
die falsche einstellung betrifft wahrscheinlich deinen web server.

welches howto hast du befolgt?

Hmm okay…
Also gemacht habe ich es nach der Anleitung: https://pastebin.com/7zhWZEuP auf Grundlage von https://www.youtube.com/watch?v=PSMqa__ipuM
Ich habe dann aber die Config selbst machen müssen, weil diese Anleitung auf Apache läuft (wahrscheinlich wirds wohl daran liegen…)
Auf meinem Server (Ubuntu 18.04) sind derzeit MariaDB, PHP7.4, Joomla und Jitsi Meet im Docker - alles über nginx
Und nun sollte noch Nextcloud dazu…

Hier noch meine Config-Datei:

upstream php-handler {
server 127.0.0.1:9000;
server unix:/var/run/php/php7.4-fpm.sock;
}

server {
listen 80;
listen [::]:80;
server_name cloud.DOMAIN.de;
include /etc/nginx/global/redirect.conf;
# enforce https
return 301 https://$server_name:443$request_uri;

}

server {
listen 443 ssl http2;
listen [::]:443 ssl http2;
server_name cloud.DOMAIN.de;
root /var/www/html/nextcloud;
include /etc/nginx/global/ssl.conf;

    ssl_certificate /etc/ssl/private/cloud.DOMAIN.de_ecc/fullchain.cer;
    ssl_certificate_key /etc/ssl/private/cloud.DOMAIN.de_ecc/cloud.DOMAIN.de.key;
    ssl_trusted_certificate /etc/ssl/private/cloud.DOMAIN.de_ecc/ca.cer;

    add_header Strict-Transport-Security "max-age=15768000; includeSubDomains; preload;";
    add_header X-Content-Type-Options nosniff;
    add_header X-XSS-Protection "1; mode=block";
    add_header X-Robots-Tag none;
    add_header X-Download-Options noopen;
    add_header X-Permitted-Cross-Domain-Policies none;
    add_header Referrer-Policy no-referrer;

    # Remove X-Powered-By, which is an information leak
    fastcgi_hide_header X-Powered-By;

    location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;
    }
    location = /.well-known/carddav {
    return 301 $scheme://$host:$server_port/remote.php/dav;
    }

    location = /.well-known/caldav {
    return 301 $scheme://$host:$server_port/remote.php/dav;
    }

    # set max upload size
    client_max_body_size 512M;
    fastcgi_buffers 64 4K;

    # Enable gzip but do not remove ETag headers
    gzip on;
    gzip_vary on;
    gzip_comp_level 4;
    gzip_min_length 256;
    gzip_proxied expired no-cache no-store private no_last_modified no_etag auth;
    gzip_types application/atom+xml application/javascript application/json application/ld+json application/manifest+json application/rss+xml application/vnd.geo+json application/vnd.m$

    location / {
            rewrite ^ /index.php;
    }

    location ~ ^\/(?:build|tests|config|lib|3rdparty|templates|data)\/ {
            deny all;
    }

    location ~ ^\/(?:\.|autotest|occ|issue|indie|db_|console) {
            deny all;
    }

    location ~ ^\/(?:index|remote|public|cron|core\/ajax\/update|status|ocs\/v[12]|updater\/.+|oc[ms]-provider\/.+)\.php(?:$|\/) {
            fastcgi_split_path_info ^(.+?\.php)(\/.*|)$;
            set $path_info $fastcgi_path_info;
            try_files $fastcgi_script_name =404;
            include fastcgi_params;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $path_info;
            fastcgi_param HTTPS on;
            # Avoid sending the security headers twice
            fastcgi_param modHeadersAvailable true;
            # Enable pretty urls
            fastcgi_param front_controller_active true;
            fastcgi_pass php-handler;
            fastcgi_intercept_errors on;
            fastcgi_request_buffering off;
    }

    location ~ ^\/(?:updater|oc[ms]-provider)(?:$|\/) {
            try_files $uri/ =404;
            index index.php;
    }

}

fehlt das?

location ~ \.(?:css|js|woff2?|svg|gif|map|png|html|ttf|ico|jpg|jpeg)$ {
  try_files $uri /index.php$request_uri;
  access_log off;
  expires 360d;
}

wobei in der “offiziellen” nextcloud doku ist das noch einen ticken anders.

https://docs.nextcloud.com/server/18/admin_manual/installation/nginx.html?highlight=nginx

ansonsten entspricht dein setup dem howto von carsten: [URL removed - Spam protection [JK]]

Ich habe den kompletten css-Block aus der “offiziellen” Anleitung entnommen, damit ging es!
Vieeeelen Dank für die schnelle und unkomplizierte Hilfe!