[SOLVED] Error while updating

Did you pressed the Retry button?

Could you open the web developers tools during the upgrade and check the last request (once this happens) and send us the response. It seems that there is something going wrong while creating the backup.

1 Like

Yes I did press retry, to no avail.

I am no tech and I don’t know where in the dev tools I should search. I use Firefox, here are the tabs I have

That is the correct tab. Now press “retry” or start the updater again. Because this tab is only filled, when the dev tools are opened.

Not sure what you’re looking for… I screencapped this, as it was the only thing that seemed of any interest… (This after the error message appeared)

I need the response tab. Best would be of all of the previous ones as well. (so en-tetes and reponse)

Here they are



Hi there,

I take the liberty to up this post since I still cannot update my Nextcloud instance.

Nextcloud version: 11.0.1
OS: Debian / shared hosting
Apache : 2.4.10
PHP version: 5.6.30
All details there http://ismayotte.lautre.net/www/phpinfo.php

Thanks for any hint you can provide me with…

@lukasreschke Do you have any idea, why this is happening?

@Pourrito Could you maybe show the same screens of the other POST requests to index.php?

I’m afraid I don’t know what you mean. :sweat:
How do I do that ?

I’m having the same issue with update from 11.0.2 --> 11.0.3 using the updater.

First I get a failure message:

Create backup
Parsing response failed. 500 Internal Server Error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@next.awequest.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.

Then when pressing “retry” I get the following:

Parsing response failed. Step 4 is currently in process. Please reload this page later.

Resetting seems to involve:

  1. Getting out of maintenance mode: open /config/config.php and change the line
    'maintenance' => true,
    to
    'maintenance' => false,
  2. Removing the file: /data/updater-{rand-string}/.step

This allows me to try the updater again, but it has failed at least 3 times. There used to be a manual way to backup and proceed on earlier versions. Is that still an option? Obviously the direct method via the browser would be best, but I’m open to alternatives.

Running no shared hosting environment (which could be the cause of issues, uncertain). Happy to provide whatever I can to troubleshoot.

Dumb question: Is there actually enough space to create a full backup including zip download before? Or to the developers: Would there be a meaningful error response if this was the case?

You can still do it manually:

  1. Maintenance mode
  2. Move content of nextcloud folder to backup location.
  3. Download newest server release: https://download.nextcloud.com/server/releases/nextcloud-11.0.3.zip
  4. Extract it to old nextcloud location.
  5. Copy config.php, potentially changes to .htaccess, themes and 3rd party apps back from backup. Or better install 3rd party apps fresh from app store, if no manual changes to some info.xml was made.
  6. Move data folder back in place, if it was actually inside nextcloud folder.
  7. Disable maintenance mode again and try.
1 Like

Hi ! Thanks for the manual instructions !

Indeed, since the 11.0.2 ->11.0.3 upgrade, I always get a timeout when the backup is being made. (hosted server). Even on a clean NC instance.

I wonder what changed meanwhile. Probably server related !

Hmm, I get a blank page after manually upgrading (and retaining the config and data files).

Actually, I’m stuck at the moment, because I use shared hosting.

What settings should I modify to use the updater app with a greater timeout value (or to be able to skip the backup step, which is where the timeout actually occurs) ?

I used to be able to upgrade with the updater app.

Thanks a lot :slight_smile:

Hmm, I re-tried the updater app several times in a row and it eventually succeeded :slight_smile:

I finally solved the issue, and managed to update to 11.0.4.

When I tried it, I still got the same error at stage 4. Even while using the try again button, I got stuck.

I then went to the config.php file changed the line maintenance = "true" to “false”, without reverting anything else, and next time I went to the update page, I clicked on the “try again” button, and it went through.

Hope it can help someone one day.

1 Like

Hi ! I still get this issue when updating. I know how to revert it, but it almost always timeouts at the “create backup” step. Any idea on how to improve the situation ? That’s probably due to a slow server ? Is it possible to skip the create backup step ?

I got this now on each of latest three minor updates of Nextcloud 12.0.x, and retrying (after changing maintenance mode by editing config.php) eventually succeeds.

As it seem to hit several users, i think it would be a good if this problem got further checked. Some progress indication or logging may help debugging it.

There are some reports on failing automatic backups (especially in hosted environments):


Feel free to open a feature request in the same repository to omit the backup step. Or for another report with more details to help to tackle this problem.

This topic here is solved, so we will close the discussion. Please open new topics for new problems.