Solved - Empty Logs when check Admin Overview

Edit, solved by 2 posts, but I can only flag one.
Many thanks to all concerned.


When I run the Administration Overview, it tells me that there are 44 (increasing) errors and to check for errors and warnings in the log, however when I click the link, it’s empty.

v.28.0.1 in a docker on OMV, Pi 4

1 Like

Hi @phreatic,
You are missing the required support template. Please fill this form out and edit into your post.

This will give us the technical info and logs needed to help you! Thanks.

1 Like

Sorry. I’ve posted what I can find - I think that some files are elsewhere in a docker environment.
I’ll keep digging.



Nextcloud version (eg, 26.0.1): 28.0.1
Operating system and version (eg, Ubuntu 22.04): Linux 6.1.21-v8+ aarch64
Apache or nginx version (eg, Apache 2.4.25): nginx 1.18.0 (SWAG)
PHP version (eg, 8.1): 7.4.33
Database (sqlite or MariaDB or Postgres) MariaDB
Docker (compose)
Is this the first time you’ve seen this error? yes
The issue you are facing: Errors reported but can;t display logs to attempt remedy.
Steps to replicate it:
Browse to :
and see 50 (increasing) errors reported.
Click the link to examine log :
and the page is empty…

The output of your Nextcloud log in Admin > Logging:
PASTE HERE : This is the page that’s empty
The output of your config.php file in /path/to/nextcloud**
(use https://…/settings/admin/support which auto-removes identifying information!):

Operating system: Linux 6.1.21-v8+ #1642 SMP PREEMPT Mon Apr 3 17:24:16 BST 2023 aarch64

Webserver: nginx/1.24.0 (fpm-fcgi)

Database: mysql 10.11.5

PHP version: 8.2.13

Modules loaded: Core, date, libxml, pcre, zlib, filter, hash, json, random, readline, Reflection, SPL, session, zend_test, cgi-fcgi, bcmath, bz2, ctype, curl, dom, fileinfo, ftp, gd, gmp, iconv, standard, intl, ldap, mbstring, openssl, pcntl, PDO, pgsql, posix, imap, SimpleXML, sockets, sodium, sqlite3, sysvsem, xml, xmlwriter, zip, exif, mysqlnd, pdo_pgsql, pdo_sqlite, Phar, xmlreader, pdo_mysql, apcu, msgpack, igbinary, redis, memcached, imagick, mcrypt, smbclient, libsmbclient, Zend OPcache

Nextcloud version: 28.0.1 -

Updated from an older Nextcloud/ownCloud or fresh install:

Where did you install Nextcloud from: unknown

Signing status

List of activated apps


  • activity: 2.20.0
  • bruteforcesettings: 2.8.0
  • calendar: 4.6.1
  • cloud_federation_api: 1.11.0
  • comments: 1.18.0
  • contacts: 5.5.0
  • contactsinteraction: 1.9.0
  • dashboard: 7.8.0
  • dav: 1.29.1
  • federatedfilesharing: 1.18.0
  • federation: 1.18.0
  • files: 2.0.0
  • files_pdfviewer: 2.9.0
  • files_reminders: 1.1.0
  • files_sharing: 1.20.0
  • files_trashbin: 1.18.0
  • files_versions: 1.21.0
  • firstrunwizard: 2.17.0
  • logreader: 2.13.0
  • lookup_server_connector: 1.16.0
  • nextcloud_announcements: 1.17.0
  • notifications: 2.16.0
  • oauth2: 1.16.3
  • password_policy: 1.18.0
  • passwords: 2023.12.31
  • photos: 2.4.0
  • privacy: 1.12.0
  • provisioning_api: 1.18.0
  • recognize: 6.0.1
  • recommendations: 2.0.0
  • related_resources: 1.3.0
  • serverinfo: 1.18.0
  • settings: 1.10.1
  • sharebymail: 1.18.0
  • support: 1.11.0
  • survey_client: 1.16.0
  • systemtags: 1.18.0
  • tasks: 0.15.0
  • text: 3.9.1
  • theming: 2.3.0
  • twofactor_backupcodes: 1.17.0
  • user_status: 1.8.1
  • viewer: 2.2.0
  • weather_status: 1.8.0
  • workflowengine: 2.10.0
  • admin_audit
  • circles: 27.0.1
  • encryption
  • files_external
  • files_rightclick: 1.6.0
  • suspicious_login
  • twofactor_totp
  • updatenotification: 1.17.0
  • user_ldap
Configuration (config/config.php)

“datadirectory”: “REMOVED SENSITIVE VALUE”,
“passwordsalt”: “REMOVED SENSITIVE VALUE”,
“trusted_domains”: [
“dbtype”: “mysql”,
“version”: “”,
“overwrite.cli.url”: “”,
“overwritehost”: “”,
“overwiteprotocol”: “https”,
“dbport”: “”,
“dbtableprefix”: “oc_”,
“mysql.utf8mb4”: true,
“installed”: true,
“trusted_proxies”: “REMOVED SENSITIVE VALUE”,
“default_phone_region”: “GB”,
“mail_from_address”: “REMOVED SENSITIVE VALUE”,
“mail_smtpmode”: “smtp”,
“mail_sendmailmode”: “smtp”,
“mail_smtphost”: “REMOVED SENSITIVE VALUE”,
“mail_smtpport”: “465”,
“mail_smtpauth”: 1,
“mail_smtpname”: “REMOVED SENSITIVE VALUE”,
“mail_smtppassword”: “REMOVED SENSITIVE VALUE”,
“mail_smtpsecure”: “ssl”,
“memcache.local”: “\OC\Memcache\APCu”,
“filelocking.enabled”: “true”,
“memcache.locking”: “\OC\Memcache\APCu”,
“loglevel”: 2,
“maintenance”: false,
“upgrade.disable-web”: true

Cron Configuration: Array
[backgroundjobs_mode] => cron
[lastcron] => 1703439602

External storages: files_external is disabled

Encryption: no



Browser: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/ Safari/537.36 Edg/

for Docker/Podman list environment variables ( run “docker inspect {container name}”)**
The output of your Apache/nginx/system log in /var/log/____: Sorry I can’t find this
For Docker/Podman post STDOUT of the container (run docker logs {container name})
errors in nextcloud.log in /var/www/ or as admin user in top right menu, filtering for errors.
Sorry, I can’t find this.

Ah, just found what looks like the same thing here, but my German is not too good. :wink:

Nextcloud 28 -errors in the logs since - :globe_with_meridians: Non-english support / :de: Deutsch (german) - Nextcloud community

1 Like
  • Disable adblocker/privacy filters for your Nextcloud URL
  • Make sure you updated your NGINX configuration was updated (as noted in the NC27 release notes but sometimes people overlook them)[1]

[1] Upgrade to Nextcloud 27 — Nextcloud latest Administration Manual latest documentation


I have the same problem as @phreatic has and a similar configuration (docker on OMV but not on a Pi.
When I was on NC 27.? I could see the logs page. Now I’m on v. 28.0.0 and the logs page is empty.
After your answer to @phreatic, I disabled the adblcoker but the logs is still empty.
I didn’t look to the configuration of Nginx when I upgraded to v. 27 so I will take a look in the next days.

with 28.0.0 everybody has the problem. with 28.0.1 the problem is solved in general but mBlock is known to cause the problem as well with 28.0.1.


thanks for mentioning, that has been the problem in our installation of 28.0.1 where logging and activity always were only white pages.
I had forgotten to update the nginx config to allow .mjs file extensions. :wink:


I must be being really dim, I’m running Nextcloud and SWAG in a docker, is the file I need to edit nextcloud.subdomain.conf in my /appdata/swag/nginx/proxy.confs directory?

I tried this and there was no change.
Thanks all.

In my docker configuration, I made the change here: appdata/nextcloud/config/nginx/nginx.conf.
After, restart Nginx service and Nextcloud docker.
It works for me.

1 Like

Thank you, I’ll try that later when I get home .

That appears to have worked, thank you again.

works too … when put

application/javascript mjs;


1 Like

Thank you, I tried there, but no joy, even after a reboot, however once it did work, I can’t break it now by removing the file type :grinning:

When the file type has beed added from either config file, is it stored somewhere else?

me not shure if we are on the same page,
logs not shown in webinterface was solved for me with that.
a closer look here see post here in forum

i put

 application/javascript mjs;

because it was simple not there
(and my nginx config /etc/nginx/nginx.conf says/requested
include /etc/nginx/mime.types; )

therfore adding it in


after that i restarted

systemctl restart php8.2-fpm.service nginx.service

all because


this was not working

# only for Nextcloud like below:

    include mime.types;
    types {
        text/javascript js mjs;

after the restart the logs appeared within the blink of an eye :wink:
and a list of other sort of errors were gone.

Yes, we are.
I think I had the same issue as you with it not working in mime.types, but under @jobal 's advice, I put it in appdata/nextcloud/config/nginx/nginx.conf.

Somewhere along the line it started working, although I’m not 100% sure which step did it.

1 Like

in php.ini i add, “AddType application/javascript .mjs” and warning disappeared