*** SOLVED *** (Davdroid was the culprit) *** Contacts won't sync into my Android phone

Nextcloud version (tried several versions: 11.0.1 and 11.0.2 and also latest daily 1.4.2017):
Operating system and version (eg, linux mint 17.3):
Nginx v 1.10.1
PHP version 7.1.3
Is this the first time you’ve seen this error?: yes

Can you reliably replicate it? (If so, please outline steps):

  1. clean flash new android 7.1.1 ROM (tried two different roms, same issue)
  2. install latest Davdroid sync app from F-Droid
  3. try to sync contacts and calendar
  4. contacts won’t sync (but calendar syncs normally) --> i.e. I cannot get my contacts from my Nextcloud instance into my android phone. It used to work fine before (I’ve done this thousand times).

The issue you are facing:
Contacts won’t sync from owncloud into my phone.

The output of your Nextcloud log in Admin > Logging:

Sabre\DAV\Exception\NotFound: HTTP/1.1 404 File not found: groups in 'addressbooks'

/usr/share/nginx/owncloud/3rdparty/sabre/dav/lib/DAV/Tree.php - line 76: Sabre\DAV\SimpleCollection->getChild('groups')
/usr/share/nginx/owncloud/3rdparty/sabre/dav/lib/DAV/Tree.php - line 71: Sabre\DAV\Tree->getNodeForPath('addressbooks/gr...')
/usr/share/nginx/owncloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 939: Sabre\DAV\Tree->getNodeForPath('addressbooks/gr...')
/usr/share/nginx/owncloud/3rdparty/sabre/dav/lib/DAV/CorePlugin.php - line 336: Sabre\DAV\Server->getPropertiesForPath('addressbooks/gr...', Array, 1)
[internal function] Sabre\DAV\CorePlugin->httpPropFind(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/usr/share/nginx/owncloud/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
/usr/share/nginx/owncloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 479: Sabre\Event\EventEmitter->emit('method PROPFIND', Array)
/usr/share/nginx/owncloud/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/usr/share/nginx/owncloud/apps/dav/lib/Server.php - line 227: Sabre\DAV\Server->exec()
/usr/share/nginx/owncloud/apps/dav/appinfo/v2/remote.php - line 30: OCA\DAV\Server->exec()
/usr/share/nginx/owncloud/remote.php - line 165: require_once('/usr/share/ngin...')

What is the main folder of your setup? /usr/share/nginx/owncloud/oc?

its /usr/share/nginx/owncloud

That error message might have been generated during an upgrade process between different Nextcloud installations. During this time my desktop computer probably has tried to access the cloud.

I am also experiencing exactly the same symptoms that the original poster above describes.

It turns out that Davdroid was the culprit. I noticed that I had tested almost everything else except previous versions of Davdroid. Once I downgraded it, the sync started working! I need to file a Davdroid bug report instead.

To which version of davdroid did you downgrade?