[SOLVED]Collabora stops working after server reboot

i am having problems that collabora stops working after server reboot eventhough after install it worked just fine. The only solution for me i have found is to remove it and have a fresh start. But again after reboot it stops working. The note while trying to open documents is well known “Well, this is embarrasing, we cannot connect to your document”.

Server runs Debian8.8 and i switched storage driver of docker to deviceMapper. My apache config is default from the official tutorial.

Container log looks like this after trying to open some document.

wsd-00026-00316 18:04:55.510965 [ docbroker_047 ] ERR No socket associated with WebSocketHandler 0x0x7f14f0013280| ./net/WebSocketHandler.hpp:110
wsd-00026-00320 18:05:54.895110 [ docbroker_048 ] ERR Cannot get file info from WOPI storage uri [https://NEXTCLOUDDOMAIN.cz/index.php/apps/richdocuments/wopi/files/84_octbes9fqe24?access_token=CV5RJCcrDML7pgAzfJQXNAUoFiFuXsaU&access_token_ttl=0&permission=edit]. Error: DNS error: Temporary DNS error while resolving: NEXTCLOUDDOMAIN | wsd/Storage.cpp:476
wsd-00026-00320 18:05:54.897262 [ docbroker_048 ] ERR Failed to add session to [NEXTCLOUDDOMAIN:443/index.php/apps/richdocuments/wopi/files/84_octbes9fqe24] with URI [https://NEXTCLOUDDOMAIN/index.php/apps/richdocuments/wopi/files/84_octbes9fqe24?access_token=CV5RJCcrDML7pgAzfJQXNAUoFiFuXsaU&access_token_ttl=0&permission=edit]: DNS error| wsd/DocumentBroker.cpp:801
wsd-00026-00320 18:05:54.898233 [ docbroker_048 ] ERR Error while loading : DNS error| wsd/LOOLWSD.cpp:2106

Dont you have any advice, please?

Are you using firewalld?

I improved by restarting Docker.

I am not.

However I completely reinstalled docker one more time and removed all config files and it automagically works. Even after reboot. Don’t know where the problem was, but it’s good now. Thanks anyway :slight_smile: