[solved] Collabora shows grey frame when opening document

I´m using the most recent versions of Nextcloud (11.0.2) and Collabora CODE (2.0.4) docker container on Debian Jessie.

I always had the problem that I only got a grey frame when I tried to open a document. With the help of annother post in this forum I found out, that Debians Apache configuration causes the problem.
To be more specific, the issue is the “Header set X-Frame-Options: “sameorigin”” from Debians “/etc/apache2/conf-enabled/security.conf” conifg file.

A smart workaround is to add “Header unset X-Frame-Options:” to the Apache site configuration file for Collabora.
It would be great if this could be added to the documentation.


I had this issue and it was unrelated to X-Frame-Options.
I run UNRAID with two docker containers:

  1. Letsencrypt (runs an nginx proxy)
  2. Collabora CODE

Because the proxy server was also in a docker container, I had to change localhost to the ip address of my host machine.

  1. In the nginx proxy config: localhost -> <host ip>
  2. In the docker run command:-p -> -p <host ip>:9980:9980

Hope this helps someone!