[Solved] Can't login to Nextcloud with any app

Nextcloud version: 13.0.1
Operating system and version: Ubuntu 16.04.4
Apache or nginx version: Apache/2.4.18
PHP version: 7.0.28

The issue you are facing:
Can’t login to my server with the Windows Desktop / Android app using the auto generated app password or the regular web login.

The output of your Nextcloud log in Admin > Logging :

webdav	Sabre\DAV\Exception\NotAuthenticated: No 'Authorization: Basic' header found. Either the client didn't send one, or the server is misconfigured, No 'Authorization: Bearer' header found. Either the client didn't send one, or the server is mis-configured
[internal function] Sabre\DAV\Auth\Plugin->beforeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/var/www/vhosts/maxmustermann.de/cloud.maxmustermann.de/3rdparty/sabre/event/lib/EventEmitterTrait.php - line 105: call_user_func_array(Array, Array)
/var/www/vhosts/maxmustermann.de/cloud.maxmustermann.de/3rdparty/sabre/dav/lib/DAV/Server.php - line 466: Sabre\Event\EventEmitter->emit('beforeMethod', Array)
/var/www/vhosts/maxmustermann.de/cloud.maxmustermann.de/3rdparty/sabre/dav/lib/DAV/Server.php - line 254: Sabre\DAV\Server->invokeMethod(Object(Sabre\HTTP\Request), Object(Sabre\HTTP\Response))
/var/www/vhosts/maxmustermann.de/cloud.maxmustermann.de/apps/dav/appinfo/v1/webdav.php - line 80: Sabre\DAV\Server->exec()
/var/www/vhosts/maxmustermann.de/cloud.maxmustermann.de/remote.php - line 164: require_once('/var/www/vhosts...')
{main}

Thanks in advance!

Found the solution:
The .htaccess was completely broken (probably due to unzipping process), after replacing it with the right version, everything worked fine again.