[Solved] Cannot access server with desktop and mobile clients but can access web and dav interface

Sorry to hear you’re facing problems :slight_frown:

If you’re urgently looking for support to keep your business running, consider checking out our paid support options.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the following as you can (you can cut and paste this into your topic):


Nextcloud version (eg, 10.0.2): 11.0.2
Operating system and version (eg, Ubuntu 16.04): openSUSE Tumbleweed
Apache or nginx version (eg, Apache 2.4.25): 2.4.25
PHP version (eg, 5.6): 7.1.2
Is this the first time you’ve seen this error?: Yes

Can you reliably replicate it? (If so, please outline steps): Yes

  1. I use a router which has a public ip address 84.249.204.100 and the home server has LAN address 192.168.1.99. I use NAT to point 80 and 443 port to the home server, so it can be accessed on the internet.

  2. I have a laptop, connected to the same router. I can open the website but the linux desktop client cannot access the server. it gives a “operation canceled” and “cannot found nextcloud” errors.

  3. I have a android phone, with 4G connection. Nextcloud Android client cannot access the server either. But DAVdroid and website can access.

  4. This happened immediately after I upgrade from 10.0.1 to 11.0.2.

The issue you are facing:

All official clients cannot sync with server. But I can visit website and use CalDAV and CardDAV.

The output of your Nextcloud log in Admin > Logging:

Failed to load /srv/www/htdocs/nextcloud/apps/contacts/l10n/zh_CN.json - json error code: 3
(this error repeats hundreds of times but seems not related to my problem)

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

The output of your Apache/nginx/system log in /var/log/____:

Nothing recently.


Remember, this information may be requested if it isn’t supplied; for fastest response please provide as much as you can :heart: Feel free to use a pastebin service, otherwise log files can be indented with 4 spaces on each line to present them in a friendlier way on the forum.

I solved this problem by updating server network settings. Maybe it is not the problem of Nextcloud.

Having almost the exact same problem but android works for me. What did you update to make it work?

I just set the static ip address for my home server and reboot the server. I am using a NAT network. This is the reason. If you are not using NAT, my solution may not be solution for your problem.