[Solved] Appstore was not working after upgrade to Nextcloud 13

After the Upgrade from Nextcloud 12.0.4 to Nextcloud 13 via the admin panel, the app store was not showing anymore correctly in the admin “Apps” section – i just saw installed apps and the categories “enabled” and “disabled” but none of the further categories of the app store. I noticed that it tried to load something in the UI section, but nothing ever appeared.

A look into my log showed me this:

file_put_contents(/var/www/data/appdata_ocuvpurfksvx/appstore/apps.json): failed to open stream: No such file or directory at /var/www/owncloud/lib/private/Files/Storage/Local.php#218

I checked permission on the appdata_ocuvpurfksvx directory which seemed fine, but I noticed that the subdir “appstore” was missing. So I created the dir, and since then the appstore is working again.

Shouldn’t this dir be created by nextcloud if missing?

Yes, file a bug here https://github.com/nextcloud/server/issues

Same thing now, 21.0.4,
only your apps, active, disabled, bundles, featured apps.
No more categories.
This bug I can find all over and over the forum, meaning it’s been a problem not identified nor solved so far for years.

The App Store is down or/and really slow at the moment. Since a Nextcloud update was released today, I assume that the store is simply overloaded. Just wait for a few hours.

$ curl --max-time 10 https://apps.nextcloud.com/
curl: (28) Operation timed out after 10003 milliseconds with 0 bytes received

Here no performance problems with access https://apps.nextcloud.com .

@Piotr-Fr Please open an own thread and post details (logs, screenshots, …)

There were definitely performance issues, but currently the App Store is available again.

Yes. The server performance is often bad. Wait for the next nextcloud release.

apps.nextcloud.com / / AS24940 Hetzner Online GmbH

I know… I know… actually a pity. :-/

The solution: