[Solved] 17.0 > - Files not showing on WebGUI - Uncaught TypeError: Handlebars.compile is not a function

Hi Nextcloud community,

I’ve upgraded from 17.0 to manually (copy data/ and config/config.php, ran “occ upgrade”.

Since then I can’t see any files on the Webgui: https://i.imgur.com/WixMyi6.png

What I have done so far:

  • So I’ve ran “occ files:scan --all”, no success
  • I’ve disabled all apps: https://i.imgur.com/m0u7bVM.png , no success
  • restarted nginx as well as php fpm
  • Then I’ve checked if all files belong to the correct User “$ find . ! -user www-data -print”, no success
  • Then I took a look at the Browser: https://i.imgur.com/BxvKDv5.png
  • So I figured that I must have messed up something on installation/upgrade

So I exploded the zipfile again, changed ownership, copied config/config.php as well as moving data/. Tried upgrading “$ sudo -u www-data php occ upgrade
Nextcloud is already latest version”

So that didn’t change anything and I am running out of Ideas.

I’ve uploaded the last 100 lines of the Log to: https://pastebin.pl/view/0614eb28

Could someone please point me what I’ve done wrong?

Server base OS: ubuntu 18.04, nignx 1.14.0, php 7.2.24

Thanks in advance.


A “sudo -u www-data php occ maintenance:mode --on
sudo -u www-data php occ maintenance:repair
sudo -u www-data php occ maintenance:mode --off” did the trick.