Softaculous Update Fehler 11.0.3

Servus Miteinand,

ich nutze auf meinem Plesk Webspace Nextcloud mit Hilfe von Softaculous.
Jedoch wird mir wĂ€hrend des Updates ein Fehler angezeigt, und die Installation ist “beendet” bzw. meine Cloud befindet sich im Wartungsmodus.
Fehlermeldung:
Log-Level auf “debug” gesetzt
Wartungsmodus eingeschaltet
Dankenbank-Schema wird aktualisiert
Datenbank aktualisiert
Es ist ein Fehler aufgetreten

Nach einem Backup via Softaculous funktioniert die Cloud zwar wieder, aber leider ohne Update

Jetzt muss ich sagen, das ich nicht die grĂ¶ĂŸten Server erfahrungen habe und auch nicht all zu viel Ă€ndern kann, da dies nur ein gemieteter Service ist.

Aber vielleicht kann mir ja hier einer helfen? :slight_smile: oder hat schon das gleiche Probleme lösen können!

Danke!
Liebe GrĂŒĂŸe!:yum:

Hallo mach das Update noch mal und danach wenn der Fehler wieder Kommt gehst du einfach her und bearbeitest du die /Nexcloud/config/config.php dort suchst du nach maintenance=> true und machst maintenance=> false drauß ^^

Sollte dann wieder starten denn der rest wurde ja gemacht ^^ Ach ja Ordner die nicht zur Nexcloud gehören um Ordner selbst /Nexcloud/ soltest du vorher raus verschieben und dann wieder zurĂŒck ^^

1 Like

Hallo NextGerneration,
vilen Dank fĂŒr deine fixe Antwort! :slight_smile:
Woran liegt dieses Problem denn?

Habe das Update fix via Softaculous gemacht, und danach deine “Anleitung” befolgt, jedoch leider kein Erfolg :frowning: Nach dem neuladen, möchte die Cloud wieder ein Update machen
 also eine Endlosschleife

Jetzt hab ich es via FTP probiert die Dateien mit der neuen Version zu ersetzen, und gleiche Fehlermeldung, aber dieses Mal geht deine “Anleitung” und siehe da es klappt

Nur keine Ahnung warum das Update via Softaculous nicht klappt


Jedoch hab ich jetzt eine neue Fehlermeldung:
Einige Dateien haben die IntegritĂ€tsprĂŒfung nicht bestanden. WeiterfĂŒhrende Information findest du in unserer Dokumentation. (Liste der ungĂŒltigen Dateien 
 / Erneut analysieren
)

Da die Cloud auf einer extra angelegten Subdomain liegt, gibt es außer der Nextcloud eh keine anderen Ordner ^^

Gruß

Eine Cloud ist wie bei vielen Programmen sensiebel ^^ Ich tippe darauf das die angelegten Ordner nicht alle die Nötigen rechte bekommen haben -.- das nÀchste mal gib der ganzen Cloud 777 rechte und versuch es dann mit dem updaten vieleicht geht es dann gleich ^^ danach drauf achten das die rechte wieder den vorgaben entsprechen nach dem update ^-

Der fehler kommt bei mir ab und an auch sollte aber normal nach dem zweiten ladn der seite weg sein ansonsten in der Config anpassen und schaun was da fehlt ^^

das mit dem ordner sag ich weil es leute gibt die Extra ordner in die cloud ablegen ^^ die machen dann aber Probleme beim updaten ^^

hm
 ja das könnte sein die Cloud hat momentan 755, aber teste diese Variante bei dem nĂ€chsten Update. - Habe nĂ€mlich die Cloud jetzt nocheinal sauber neuinstalliert, war zum GlĂŒck noch nicht all zu viel drauf :slight_smile:
Aber werde dich sobald es ein neues Update gibt sofort Informieren, ob es geklappt hat oder nicht! :slight_smile:

Ja leider war in dem Fehlerbericht sehr viel, sodass ich mich halt fĂŒr eine saubere Installation entschieden hab :smiley:
Hier ein kleiner Auszug der Fehlerdatei


- core
	- EXTRA_FILE
		- nextcloud/config/config.sample.php
		- nextcloud/config/.htaccess
		- nextcloud/core/signature.json
		- nextcloud/updater/updater.phar
		- nextcloud/updater/index.php
		- nextcloud/themes/README
		- nextcloud/themes/example/core/img/favicon-touch.png
		- nextcloud/themes/example/core/img/favicon.svg
		- nextcloud/themes/example/core/img/logo-icon.png
		- nextcloud/themes/example/core/img/logo.png

Bei einer anderen Cloud bekam ich nur diese Fehlermeldung:

  • core
    • INVALID_HASH
      • .htaccess
      • 3rdparty/composer.json
      • 3rdparty/composer.lock
      • 3rdparty/composer/ClassLoader.php
      • 3rdparty/composer/autoload_classmap.php
      • 3rdparty/composer/autoload_real.php
      • 3rdparty/composer/autoload_static.php
      • 3rdparty/composer/installed.json
      • version.php

:smiley: okay, ist ja kein Problem, könnte mir bestimmt auch passieren


Aber danke dir :slight_smile: