Snappy package is not updated automatically from 15.0.5snap1 to 15.0.7snap1

snap
#1

Hi there,

I’ve installed Nextcloud with Snappy packaging system following the instruction here:

The installation went successfully and Nextcloud is running up from the start, while it looks like the package is not updated automatically.

Would someone please let me know how to update that manually or to set it updated automatically?

Here is the log by executing snap info nextcloud:

user@localhost:~$ snap info nextcloud
name:      nextcloud
summary:   Nextcloud Server - A safe home for all your data
publisher: Nextcloud✓
license:   unset
description: |
  Where are your photos and documents? With Nextcloud you pick a server of
  your choice, at home, in a data center or at a provider. And that is where
  your files will be. Nextcloud runs on that server, protecting your data and
  giving you access from your desktop or mobile devices. Through Nextcloud
  you also access, sync and share your existing data on that FTP drive at
  school, a Dropbox or a NAS you have at home.
commands:
  - nextcloud.disable-https
  - nextcloud.enable-https
  - nextcloud.export
  - nextcloud.import
  - nextcloud.manual-install
  - nextcloud.mysql-client
  - nextcloud.mysqldump
  - nextcloud.occ
services:
  nextcloud.apache:          simple, enabled, active
  nextcloud.mdns-publisher:  simple, enabled, active
  nextcloud.mysql:           simple, enabled, active
  nextcloud.nextcloud-cron:  simple, enabled, active
  nextcloud.nextcloud-fixer: simple, enabled, inactive
  nextcloud.php-fpm:         simple, enabled, active
  nextcloud.redis-server:    simple, enabled, active
  nextcloud.renew-certs:     simple, enabled, active
snap-id:      njObIbGQEaVx1H4nyWxchk1i8opy4h54
tracking:     stable
refresh-date: 38 days ago, at 03:25 JST
channels:
  stable:       15.0.7snap1               2019-04-10 (12753) 204MB -
  candidate:    ↑
  beta:         15.0.7snap1+git6.630033d  2019-04-17 (12885) 205MB -
  edge:         master-2019-04-19         2019-04-19 (12912) 210MB -
  16/stable:    –
  16/candidate: 16.0.0rc2snap1            2019-04-18 (12892) 210MB -
  16/beta:      ↑
  16/edge:      ↑
  15/stable:    15.0.7snap1               2019-04-10 (12753) 204MB -
  15/candidate: ↑
  15/beta:      ↑
  15/edge:      15-2019-04-19             2019-04-19 (12917) 205MB -
  14/stable:    14.0.7snap1               2019-02-22 (11748) 194MB -
  14/candidate: ↑
  14/beta:      14.0.7snap1+git4.c4636f0  2019-03-16 (12202) 202MB -
  14/edge:      14-2019-04-19             2019-04-19 (12920) 203MB -
  13/stable:    13.0.11snap1              2019-02-22 (11752) 188MB -
  13/candidate: ↑
  13/beta:      13.0.11snap1+git4.92e1309 2019-03-16 (12199) 193MB -
  13/edge:      13-2019-04-11             2019-04-11 (12787) 194MB -
  12/stable:    12.0.13snap1              2019-01-07 (10632) 206MB -
  12/candidate: ↑
  12/beta:      ↑
  12/edge:      ↑
  11/stable:    11.0.8snap1               2018-05-10  (6942) 202MB -
  11/candidate: ↑
  11/beta:      ↑
  11/edge:      ↑
installed:      15.0.5snap1                          (11891) 205MB devmode

It says it tracks stable but the package remains 15.0.5snap1, which should be 15.0.7snap1.

Thanks in advance,

#2

Hmm, that shouldn’t happen. Can we please see the output of the following commands?

$ snap changes

And

$ sudo snap refresh nextcloud
#3

Sorry for the late reply- I tried sudo snap refresh nextcloud again and this time it worked like a charm. Nextcloud was updated successfully.

nextcloud 15.0.7snap1 from Nextcloud✓ refreshed

I still am not sure why it took more than a week for the snappy package to be updated, though.

#4

Me neither, I expect it tried a few times previously and it failed for whatever reason. Did snap changes show anything?

#5

No, it showed nothing to me. After updating it started to show:

user@localhost:~$ snap changes
ID   Status  Spawn                   Ready                   Summary
8    Done    yesterday at 17:33 JST  yesterday at 17:33 JST  Refresh "nextcloud" snap
#6

Hi @kyrofa, just FYI the latest update to 15.0.8snap2 has been done automatically as expected.

user@localhost:~$ snap changes
ID   Status  Spawn                   Ready                   Summary
11   Done    yesterday at 13:02 JST  yesterday at 13:02 JST  Auto-refresh snap "nextcloud"
12   Done    yesterday at 18:37 JST  yesterday at 18:37 JST  Auto-refresh snap "nextcloud"

It is also confirmed on Administration -> Overview on Nextcloud admin settings page.