Snap Nextcloud set up: Can't access server outside local domain


I cannot access my newly set up nextcloud server from outside my home.


a. I’m trying to use a laptop with ubuntu 22.04 and snap to set up a nextcloud server (v. 24.0.6).
b. I am (trying) to follow the directions here.
c. My ISP is xfinity and my router is an old netgear.
I have opened up the ports 22, 80, and 443 on my router and are forwarding them to those ports on my laptop.
d. I am using as my DNS.
e. Using a self-signed ssl certificate
f. Have set up the following trusted domains
a. localhost
b. 192.168.0.*
c. (mysubdomain)

Currently, I can

  1. Log in to nextcloud via firefox/https from
    a. the laptop itself (i.e. the local host)
    b. Another laptop using the same router/LAN
  2. SSH into the laptop locally and from outside my LAN.

SInce I can ssh into my laptop, that suggests I am able to correctly config my router. However, if I try to access my NC server using firefox and the url https://<mysubdomain> or I get a message saying my browser is Unable to connect. Further, I don’t get an event logged in index.php/settings/admin/logging, which suggests that maybe I don’t have my router configured correctly.

What’s going on? Or at least, can you help me pinpoint the issue?




I guess if your are able to SSH into the server from internet via your Public IP, then router is definitely forwarding traffic properly to your local server from internet.

Try a different browser !!

Some ISPs block 80/443 on domestic connection, so verify if that is not the case. Just for testing you can put snap on a different port, forward that and try again to see if 80/443 is indeed blocked !!


You can run tcpdump on the laptop to verify whether the port is coming through if you suspect the ISP of blocking it.

1 Like

This is my guess as well.

1 Like

Thanks for your input. I had tried many of the suggestions before posting (verifying that ports are accessible via ISP, trying other browsers).

The tcpdump suggestion was new to me and it helped me diagnose the problem which was due to a simple user error. I misspecified the IP of my nextcloud server when configuring my router’s port forwarding.

I can now access the server and was even able to set up a ssl certificate. Woohoo!