Snap install on Fedora 27

So I tried the online demo, installed 10.0.4 from repos and followed the install guide and doc’s. All worked fine, but it soon becomes obvious how out-of date the repo version is.

Searched and concluded that it looks unlikely that we will see newer versions of Nextcloud via Fedora repo’s.

Uninstall 10.0.4 and remove all references to nextcloud.

So I thought I’d try installing via snap (first time using snap).

Having run snap install nextcloud I can see I have services running:

Snap Service Startup Current
nextcloud apache enabled active
nextcloud mdns-publisher enabled active
nextcloud mysql enabled active
nextcloud nextcloud-cron enabled active
nextcloud php-fpm enabled active
nextcloud redis-server enabled active
nextcloud renew-certs enabled active

Though I may also have issues with having enable HSTS with 10.0.4, I don’t know what to do next. I can’t see any response via a browser, and I’m not able to tell if or what configuration steps should be next.

Do all the native services Apache , MariaDB, etc need to be stopped? Or have I miss-understood the install/configure guide?


I’m still getting nowhere with this.

Any attempt to run the install manually from a shell is met with

Waiting for PHP…

Hi - I hit the same thing with Fedora 29.

Any ideas? What other logs can we look at?

– Patrick

I found this open issue, I’ve already re-install the nextcloud snap a few times with no change:

And, the issue in snapd itself is here: