SMTP Does Not Authenticate

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 26.0.2
Operating system and version (eg, Ubuntu 20.04): TrueNAS
Apache or nginx version (eg, Apache 2.4.25): replace me
PHP version (eg, 7.4): replace me

The issue you are facing:
SMTP does not work.
I have tried connecting to Google, Yahoo, and Outlook, using SSL, TSL and with no authentication.
In each circumstance, I get this generic error:

A problem occurred while sending the email. Please revise your settings. (Error: Email could not be sent. Check your mail server log)

I have looked through forum posts and articles online, and have not been able to resolve this by any means.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. Attempt to set up SMTP

The main thing that comes to mind to set encryption to None so that STARTTLS will be relied upon by NC to upgrade to whatever encryption is supported by the remote:

https://docs.nextcloud.com/server/latest/admin_manual/configuration_server/email_configuration.html#configuring-an-smtp-server

You can also turn on mail_smtpdebug to see more details.

If still stuck post your entire config.php redacted - or at least the mail_* parts.

1 Like