SMB share shown as empty. Any caches to be cleaned?

I have an SMB external storage “daten” which is shown in nextCloud as empty.
No matter how often I remove or add it, it is always empty.
The SMB share itself is definitely and absolutely configured correctly - I can connect with smbclient, windows clients etc.
Even more strange, when I upload files or create folders with nextCloud, they appear on the SMB share.

Now, when I change the name of the SMB share from daten to daten2 (everything else identical) it works!!

It drives me nuts!

I tried occ files:scan --all and files:cleanup. No luck

Hard to say, anything in the logs? If not, you could file a bug report, the developers can perhaps help you and tell you how to debug this further. Make sure to run a current version first.

No, nothing in the logs. Everything up to date.
I tried debugging it for a bit.
But it seems impossible to reproduce since it only seems to happen for this one single share “daten” and if I just rename it it works. I deleted and re-added hundreds of times.

But since only the share name seems to cause the problems I have the suspicion that there is some temporary data, cache etc where things gets messed up. I just don’t know where to look for that …

Probably the best is to check with the developers on github. They can help you with debugging.