SMB Share Folder Missing

Nextcloud version: 11.0.1

Operating system and version: Ubuntu 16.04.1 LTS

Apache or nginx version: 2.4.18

PHP version : 7.0.13

Is this the first time you’ve seen this error and can you replicate it?:

I’ve seen the error multiple times. Also on other installations.
But I can’t replicate it because it happens only from Time to Time.

The issue you are facing:

The issue we have is that sometimes we can’t see all subfolders of an SMB Shares.
The Data is on an Windows Server 2012 and most of the time we don’t have a problem with that.
But as said some times you open an folder an you can see only a few subfolders or none of them. You can refresh the page, logoff and login, or even use another user but you still can’t see the folder.
If you create a new Folder or Text File from Nextcloud you can refresh the page and then you can see all folders again.
I’ve already tried different things. Sometimes a complete reinstallation was needed to get rid of the failure for a few days or weeks.
Also I tried deleting the oc_filecache Table in the MariaDB and it looked good for a couple of minutes but the error came back.

The output of your Nextcloud log in Admin > Logging:

The log File sadly doesn’t have an error message regarding the issue, but still here is the link for the log right after I experienced the issue:

The output of your config.php file in /path/to/nextcloud :

$CONFIG = array (
'trusted_domains' =>
array (
0 => '',
'datadirectory' => '/var/www/nextcloud/data',
'overwrite.cli.url' => '',
'htaccess.RewriteBase' => '/',
'overwritewebroot' => '/',
'has_internet_connection' => true,
'check_for_working_htaccess' => true,
'dbtype' => 'mysql',
'version' => '',
'dbname' => 'nextcloud',
'dbhost' => 'localhost',
'dbport' => '',
'dbtableprefix' => 'oc_',
'dbuser' => 'user',
'dbpassword' => 'PW',
'logtimezone' => 'Europe/Zurich',
'installed' => true,
'memcache.local' => '\\OC\\Memcache\\APCu',
'ldapIgnoreNamingRules' => false,
'ldapProviderFactory' => '\\OCA\\User_LDAP\\LDAPProviderFactory',
'mail_smtpmode' => 'smtp',
'mail_from_address' => 'mydata',
'mail_domain' => '',
'mail_smtphost' => 'exc01.customer.local',
'loglevel' => 0,
'maintenance' => false,
'' => 'stable',
'default_language' => 'de',
'theme' => 'customer',

The output of your Apache/nginx/system log in /var/log/____:

[Fri Feb 03 06:25:02.559116 2017] [core:notice] [pid 1371] AH00094: Command line: '/usr/sbin/apache2'
[Fri Feb 03 10:03:13.330269 2017] [authz_core:error] [pid 6156] [client] AH01630: client denied by server configuration: /var/www/nextcloud/data/.ocdata
[Fri Feb 03 10:19:00.754639 2017] [authz_core:error] [pid 6160] [client] AH01630: client denied by server configuration: /var/www/nextcloud/data/.ocdata
[Fri Feb 03 10:19:58.451597 2017] [authz_core:error] [pid 6413] [client] AH01630: client denied by server configuration: /var/www/nextcloud/data/.ocdata
[Fri Feb 03 10:20:01.468310 2017] [authz_core:error] [pid 6955] [client] AH01630: client denied by server configuration: /var/www/nextcloud/data/.ocdata

Does no one have the same Issue as I?
Currently I’ve the Issue on three Installation from Nextcloud 10 to 12.

Also the File_External:Notify doesn’t help.

Haven’t seen this, no.
Raise it on GitHub too: