Smb external storage problems

I’m using Nextcloud since a while and recently updated to 23.0.2 on my ubuntu 20.04 server. Since this update I have issue on samba external storage.

When I copy big files from my smb share to my smb share in NC or download files it stops at 512MB. If I try to delete it, it doesn’t work and sometime I have a pop up which says that the file is locked. I’m also not able to delete this “incomplete file” through samba folder from my PC, I have to delete it through my server.
I can upload bigger files, this is not a problem. When I tried the same operation in NC outside of the smb share it works.
If I use windows and copy files inside my smb share, there is no problem. It seems really to be linked to NC.

Another think that I saw but I’m not sure that this didin’t occur before upgrading. The modified time of folder and files is wrong, there is one hour difference. So if I create a new folder, it is specified modified on an hour :slight_smile:
Also if create it through windows on samba folder, this time is wrong on NC.
My server and NC show the same time.

Thanks in advance

Thierry

Had the same issue yesterday. Have opened up a bug report with a work-around as well (for me at least): [Bug]: Download file > 512MB from SMB external storage not possible (NC 23.0.2) · Issue #31308 · nextcloud/server (github.com)

Thanks for answering, It is also linked to the updated in your case? For me it worked perfectly before upgrading.
Do you also have the problem if you copy a file >512MB from you smb share to your smb share using NC?

Do you also have timestamp issue in your smb share?

I do not regurly download such large files, but I think I can recall it worked on 23.0.0. Would also explain why the copy of the icewind version from 23.0.0 solved the issue.

And I have the timestamp issue as well.

There are 4 related tickets. Way of working with external storage was changed, so all files will be downloaded even on simply properties call. This could be the case here.

Did you solve your problem by installing PHP7.4-smbclient?

If yes I do not understand why smbclient which was working since a while does not work anymore.

I’m using php8.0 (was using php8.0 already on 23.0.0 as well), so I installed php8.0-smbclient, which solved my issue. Do not understand either, but it worked for me.

Did you add a PPA to install PHP8.0-smbclient?
PHP7.4-smbclient is not included in official PPA, I must add Ondrej PPA.

Does it solve the timestamp issue?

You are correct, this is coming from the Ondrej PPA.

Timestamp issue also seems to be solved by this (at least, can’t reproduce anymore).

I finally upgraded to Ubuntu 22.04 and NC 24rc1 using PHP8.1.
PHP8.1-smbclient is included in official repo.

sudo apt install PHP8.1-smbclient

This solve the issue

Nevertheless I do not recommand to upgrade to NC24 as it is not on stable channel.
Do it at your own risk. i would recommand to wait stable version which is planned for beggining of May