Small VPS not running Cron, so no News!

nc13
cron

#1

I am sorry, but I am not tech savy even on linux commands

I had help to install my nextcloud server with redis… and it has worked flawless but it works on AJAX
is there any easy workaround to put it to work

What I needed was to get selected feeds delivered to groups according to the importance for them
content groups -> blogs and media websites
web development -> technical sites
etc

I just don’t want to break my nextcloud that my friend jason got it work like a Ferrari on a Mini VPS

Thx


#2

Is there a reason that cronjobs are not running or do you just need help to set them up?


#3

I dunno the reason why maybe it wasn’t setup because he saw no need
and the VPS is just 1 Gb.

If you ask me if I need help setting them up, I do
i am zero in linux command linne unless it comes in steps by steps and errors show up

thx for your reply tflidd


#4

you can try to run it once manually from command line and see if it breaks:

sudo -u www-data php -f /path/to/nextcloud/cron.php


#5

Tried it and

Could not open input file: /path/to/nextcloud/cron.php

did find cron.php file and it is located at
/var/www/html/nextcloud/core/Command/Background/Cron.php
/var/www/html/nextcloud/cron.php

I am sure this must be easy… but for me sorry
tried correcting path and didn’t worked either… any ideas… I do need to learn linux asap

TIA


#6

I couldn’t know the path you are using, it should be the second script your found. It should normally show errors if it does not work.


#7

@tflidd and should the command be any different? I am sorry to ask you but I really do not master it.

you said for me to run
sudo -u www-data php -f /path/to/nextcloud/cron.php

it replied
Could not open input file: /path/to/nextcloud/cron.php

Since it may be located in another place
should I change the command?

Thank you so much, for being a dummy in this


#8

Please use this path. /path/to.. was only used as a place holder because the actual path can be different in each system.


#9

Got the path to /cron.php and ran it… took a while and terminal showed no errors

Now that I got to my nextcloud instance it says

Background jobs

Last job execution ran 3 hours ago. Something seems wrong.

I was so happy to see feed loading… but ain’t working


#10

then you can add this command to your cron jobs and it will be run on a regular basis. Check some documentation of your distribution on how to add a command and to run it every 15 minutes.


#11

I am running an Ubuntu 16.04 LTS
checked docs on it… but my friend tflidd you (nextcloud) did not make it easy, moreover, if it is what you recommend.

To check if cron.pho is running well I did the test
https://mydomain/cron.php
and it said success

I used nano to open crontab and added (right after the certbot renew)
*/15 * * * * php -f /var/www/html/nextcloud/cron.php
nope… came out wrong again

I do not quite feel like paying those sites to get a simple cronjob command

  • Also went looking at nextcloud documentation

can you help me with the right command in case you know

TIA
Sorry for bothering you for so long on this


#12

I thought you have a VPS with full admin rights?

With such detailed error description, don’t expect anybody to help you.


#13

If you is having problem with cron job settings, using online cron job like https://www.easycron.com as an alternative is a good idea.


#14

I did it like this.

crontab -e -u nginx

Nginx is my webserver user. With nginx it’s propably nginx. Apache and it’s www-data. Check the owner of your Nextcloud files.

After the command is run, do the same like you did with nano. If it’s still not working, add full path to your php. Like /my/php/ishere/php - f …

If still not working, read all your logs.


#15

Thanks for your help got it running, by going to a few dozens of pages but now it works

*/15 * * * * sudo -u www-data php -f /var/www/html/nextcloud/cron.php

This solved it, working like a swiss clock :grinning:

Thank you to all