Slowness between a Debian 10 Buster server and Agenda Thunderbird


When I create an event, it takes about 30 seconds to complete the process. When I delete it, it takes about 15 seconds.I have no problems on another server with Thunderbird, and it goes fast when I use the web application on my Debian 10 server.
My server uses Apache 2.4.38 and PHP 7.3.
Everything is well configured in Nextcloud 22.2.3 with a 512MB cache.
Nothing in the Apache logs.

My config.php file :

$CONFIG = array (
  instanceid' => '*************',
  'passwordsalt' => '*****************',
  secret' => '***************,
  trusted_domains' => 
  array (
    0 => '***********',
  'datadirectory' => '************',
  'dbtype' => 'mysql',
  version' => '',
  'overwrite.cli.url' => '**********',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost',
  'dbport' => '',
  dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => '**********',
  'dbpassword' => '********',
  installed' => true,
  'default_phone_region' => 'FR',
  maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'memcache.local' => '\OC\Memcache\Redis',
  'filelocking.enabled' => 'true',
  memcache.distributed' => '\OC\Memcache',
  'memcache.locking' => '\OC\Memcache\Redis',
  'redis' => 
  array (
    host' => 'localhost',
    port' => 6379,
    timeout' => 0,
    dbindex' => 0,
  'updater.secret' => '**********',' => 'stable',

Where should I look?

Thanks in advance.

Do you see the requests in the apache log? Perhaps some resource that it tries to open that fails (error 4xx, or redirect 3xx)?

Thanks for the idea but I had already thought of it; there is nothing on the Apache log side.
I suspect a problem on the DAV side but I don’t know where to look.

You mean nothing at all? Even successful access can be logged and the timestamps can reveal which resource takes too long to load. Like this I would have guessed that it could be the .well-known redirects.

Perhaps try a different caldav client as well?

I finally solved my slowness problem by installing Debian 11 and all recent versions of Apache and PHP.
On the other hand, the problem probably came back after upgrades. I also noticed that the Cron program was failing, and that the cause was that the PHP version called was V 8.1 which is not compatible with my version of Nextcloud (V 22). Here I solved the problem by changing the ad hoc symbolic links in /etc/alternatives.
Now everything works perfectly well :slight_smile:

Translated with DeepL Translate: The world's most accurate translator (free version)