Slow shared folders

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 12.0.2): 15.0.6
Operating system and version (eg, Ubuntu 17.04): Fedora 29
Apache or nginx version (eg, Apache 2.4.25): httpd-2.4.38-2.fc29.x86_64
PHP version (eg, 7.1): PHP 7.2.16

The issue you are facing:

Using the web gui, displaying the contents of a shared folder is very slow or may not complete at all for all users except the original folder owner. This is particularly for folders with many files, e.g. 267 files totalling 230Mb takes ~60 secs to display.

No obvious load is seen on the server. memcache has been configured and HTTP2 enabled.

Is this the first time you’ve seen this error? (Y/N): Yes, but this may be due to pattern of increased usage

Steps to replicate it:

  1. Share a folder with many files to one or more users
  2. Browse shared folder as other user results in slow/no render of contents

The output of your Nextcloud log in Admin > Logging:

No errors seen

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'xxxx',
  'passwordsalt' => 'xxxxxxxxxxxxxxxxxx',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/export/data/owncloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'owncloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'xxxxxxx',
  'dbpassword' => 'xxxxxxx',
  'defaultapp' => 'calendar,files',
  'forcessl' => true,
  'theme' => '',
  'installed' => true,
  'maintenance' => false,
  'overwritewebroot' => '/owncloud',
  'overwrite.cli.url' => '/owncloud',
  'mail_from_address' => 'nextcloud',
  'mail_smtpmode' => 'smtp',
  'mail_smtpdebug' => false,
  'mail_domain' => '',
  'secret' => 'xxxx',
  'memcache.local' => '\OC\Memcache\APCu',
  'memcache.distributed' => '\OC\Memcache\Redis',
  'memcache.locking' => '\OC\Memcache\Redis',
  'redis' => array(
    'host' => '/var/run/redis/redis.sock',
    'port' => 0,
    'timeout' => 0.0,
  'asset-pipeline.enabled' => false,
  'mail_smtphost' => 'x.x.x.x',
  'mail_smtpport' => '25',
  'loglevel' => 2,
  'trashbin_retention_obligation' => 'auto',
  'log_rotate_size' => 10485760,
  'appstore.experimental.enabled' => false,
  '' => 'stable',
  'mysql.utf8mb4' => true,

The output of your Apache/nginx/system log in /var/log/____:

No errors seen

I seem to be having the same problem. Owner of the folder has a reasonable fast access to the shared folder. However, access for other users is very slow.

This is with nextcloud docker 20.0.5.

My theory based on some (unrelated) tests is that the owner accesses use direct file system access. However accesses done by other users go over WebDAV which is much slower.

Is it possible to share folders “locally” so that other users access files directly, too?

Not ideal but I worked around this by migrating large folders to group folders.

1 Like