Single folder cannnot be moved or deleted, system permissions and ownership are the same as folders that can

I have a single folder that I can’t move or delete in the web UI. It’s a single folder with two tarball files. I even tried just rm -rf the directory though the shell, but it remained in the Nextcloud web UI (though I of course couldn’t view/download the files anymore, since they’d been deleted “in reality”). I copied them back through shell, and changed permissions to reflect other folders and files, but I don’t even get the “delete” option, and if I try to move, I get an error (Could not move "problem folder").

If I try that one folder, there’s no “delete” option:
Screenshot 2021-10-21 at 13.28.19

If I try any other folder, there is:
Screenshot 2021-10-21 at 13.28.26

I’ve also tried moving it in the Nextcloud folder in Finder on macOS, but this doesn’t help either.

The ownership/permissions of the “problem folder” (top) is the same as the next two (that work fine). The last four lines are some files:
Screenshot 2021-10-21 at 13.30.59

And the ownership/permissions of files with the “problem folder” .
Screenshot 2021-10-21 at 13.31.12

I really don’t see what wrong here?

Any idea how I can delete and/or move this folder? Can you for instance “trick” Nextcloud e.g. by manually editing the mariadb database, and then manually deleting it? If so, how?

Nextcloud v 22.2.0
Installed in FreeBSD jail

If you delete or have deleted the folder in the file system you must rescan the directory that Nextcloud (e.g. MariaDB) knows that the directory and files have gone.

sudo -u www php occ files:scan --all

I had to do

sudo -u www-data php --define apc.enable_cli=1 occ files:scan --all

to avoid the error below.

root@nextcloud:/usr/local/www/nextcloud # sudo -u www php occ files:scan --all
An unhandled exception has been thrown:
OC\HintException: [0]: Memcache \OC\Memcache\APCu not available for local cache(Is the matching PHP module installed and enabled?)

But thanks for the pointer!