Since NC12 folder "Documents" not accessible


I just noticed that I can’t access my folder “Documents”. After the upgrade to NC 12 yesterday I checked other folders and thought everything works fine, but first today I tried to access my documents and notice this issue.

I tried the Nextcloud App and the Web interface and the reaction is all the same: I click the folder “Documents”, the web interface is loading and flashes back to the start page (my home folder), which means I never get to see the content of the folder “Documents”. From my home folder I can still see the folder size of some MB.

There is nothing in the logs (even with log level Debug the logs are empty).
Having a look at the folder content on OS level I see a folder
drwxr-x--- 2 www-data www-data 4096 Sep 27 2016 ct' Articles

and I believe that the single quote could be the issue here - although it perfectly worked under NC11.0.3.

Can somebody tell me a save way to rename this subfolder without braking database dependencies? If I remember correctly there was a database table in NC11 that contained a list of all files and folders, but I can’t find that table now.
I read that a lot have changed in NC12 under the hood, so is the file and folder list maintained elsewhere now?

Can I securely rename the folder and do a occ files:scan --all ?

If really the single quote is the root cause of my problem I consider it a bug and would open a bug report. For now I just wanted to share this problem and also ask for help regarding a safe way to rename the folder and see the outcome.


Server configuration

Operating system: Linux nextcloud 4.4.0-78-generic #99-Ubuntu SMP Thu Apr 27 15:29:09 UTC 2017 x86_64

Web server: Apache/2.4.18 (Ubuntu) (apache2handler)

Database: mysql 5.7.18

PHP version: 7.0.18-0ubuntu0.16.04.1


Core, date, libxml, openssl, pcre, zlib, filter, hash, Reflection, SPL, session, standard, apache2handler, smbclient, redis, mysqlnd, PDO, xml, calendar, ctype, curl, dom, mbstring, fileinfo, ftp, gd, gettext, iconv, imagick, imap, intl, json, ldap, exif, mcrypt, mysqli, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, Phar, posix, readline, shmop, SimpleXML, sockets, sqlite3, sysvmsg, sysvsem, sysvshm, tokenizer, wddx, xmlreader, xmlwriter, xsl, zip, libsmbclient, Zend OPcache

Nextcloud version: 12.0.0 -

Updated from an older Nextcloud/ownCloud or fresh install:
It’s a migrated system from 10.1 via 11.0 and 11.0.3 and now 12.0


  • activity: 2.5.2
  • admin_audit: 1.2.0
  • admin_notifications: 1.0.0
  • announcementcenter: 3.1.0
  • audioplayer: 2.0.0
  • bookmarks: 0.10.0
  • bruteforcesettings: 1.0.2
  • calendar: 1.5.3
  • circles: 0.10.0
  • comments: 1.2.0
  • contacts: 1.5.3
  • dav: 1.3.0
  • external: 2.0.3
  • federatedfilesharing: 1.2.0
  • files: 1.7.2
  • files_accesscontrol: 1.2.4
  • files_downloadactivity: 1.1.1
  • files_pdfviewer: 1.1.1
  • files_sharing: 1.4.0
  • files_texteditor: 2.4.1
  • files_trashbin: 1.2.0
  • files_versions: 1.5.0
  • files_videoplayer: 1.1.0
  • firstrunwizard: 2.1
  • gallery: 17.0.0
  • groupfolders: 1.0.2
  • impersonate: 1.0.1
  • issuetemplate: 0.2.1
  • logreader: 2.0.0
  • lookup_server_connector: 1.0.0
  • nextcloud_announcements: 1.1
  • notifications: 2.0.0
  • oauth2: 1.0.5
  • ojsxc: 3.2.0
  • onlyoffice: 1.0.4
  • password_policy: 1.2.2
  • provisioning_api: 1.2.0
  • serverinfo: 1.2.0
  • sharebymail: 1.2.0
  • socialsharing_email: 1.0.1
  • spreed: 2.0.1
  • systemtags: 1.2.0
  • tasks: 0.9.5
  • theming: 1.3.0
  • twofactor_backupcodes: 1.1.1
  • twofactor_totp: 1.3.0
  • updatenotification: 1.2.0
  • workflowengine: 1.2.0


  • encryption
  • federation
  • files_external
  • sharerenamer
  • survey_client
  • user_external
  • user_ldap[/details]

If it isn’t already please create an issue in GitHub

@nickvergessen @MorrisJobke

Hi @JasonBayton

I would like to have some clarity if it’s really the single quote. This would be the nice detail to inform the developers about :slight_smile:

I don’t want to try and add another folder with a single quote in the name for testing purposes unless I know how to repair that safely :wink:

I expect so, I’ve had issues like this in the past. GH it and the devs will engage :thumbsup:

Single quotes work fine here.

Is it possible that you are using the “files access control” app? That has an issue in 12.0.0 which causes reloading into the root folder, when you enter a folder which contains a blocked item:

The fix for this needs to be done in the dav app:

1 Like

@nickvergessen, you are awesome!
(And so is this whole community.)

Thank you very much, commenting out the lines as suggested, solved the problem and I can access my “Documents” folder again.