Sharing by Group


I created a group call “Project A” and assign users to this group. Manage to share files with this group. Users in this group received email informing them of the share. The link in the email shows the internal IP address of the server ( instead of external domain name (domaincom). I have no such problem when sharing with email address.

$CONFIG = array (
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘datadirectory’ => ‘/data’,
‘instanceid’ => ‘ocvajrjx95r1’,
‘passwordsalt’ => ‘hidden’,
‘secret’ => ‘secret’,
‘trusted_domains’ =>
array (
0 => ‘’,
1 => ‘domaincom’,
‘dbtype’ => ‘sqlite3’,
‘version’ => ‘’,
‘overwrite.cli.url’ => ‘’,
‘installed’ => true,
‘mail_smtpmode’ => ‘smtp’,
‘mail_smtpsecure’ => ‘ssl’,
‘mail_sendmailmode’ => ‘smtp’,
‘mail_from_address’ => ‘noreply’,
‘mail_domain’ => ‘mail’,
‘mail_smtpauthtype’ => ‘LOGIN’,
‘mail_smtpauth’ => 1,
‘mail_smtphost’ => ‘smtp’,
‘mail_smtpport’ => ‘465’,
‘mail_smtpname’ => ‘’,
‘mail_smtppassword’ => ‘admin’,
‘ldapIgnoreNamingRules’ => false,
‘ldapProviderFactory’ => ‘OCA\User_LDAP\LDAPProviderFactory’,

‘forwarded_for_headers’ =>
array (
‘overwriteprotocol’ => ‘https’,
‘overwritehost’ => ‘domaincom’,
‘remember_login_cookie_lifetime’ => 0,
‘session_lifetime’ => 900,
‘session_keepalive’ => false,
‘maintenance’ => false,
‘theme’ => ‘’,
‘loglevel’ => 2,

Can someone advise?

Thanks and regards


Try to change IP to 1 and domain to 0 in array.


tried changing and is still the same result.

thanks anyway :slight_smile:

I have the impression, that you’re accessing the server using an IP address. If so, please use make sure that you use the domain name to access it and adjust the given parameter accordingly. Most likely this will fix your problem.

Did you login via IP or via Domain when you share with a group? NC will take this as basis, e.g. I have 2 Domains and IP configured in NC and Link will be generated based on Domain where I logged in. E.g.

array (
0 => ‘domain1’,
1 => ‘domain2’,
2 => ‘’,

If I logged in via domain2, then Link will be created for domain2. It works with domain1 if you manually change it. Regarding E-Mails I never checked what was send.

gas85 - I login via domain name. The link when shared via email shows the domain name whereas when sharing via group, it still shows the internal IP address.

j-ed - great. after changing the ‘overwrite.cli.url’ to domain name it works. thank you so much :smiley:

1 Like