Sharing by eMail - password is not send by mail


i have a problem with my fresh nextcloud 12 installation.
If i share a folder/file by mail and set a password for this sharing, the mail with the password is not sent.
In the activity app i see the notification, that the mail was send but i dont receive any mail. I check all spam folders and so on.

I configured smtp for sending mails. The check was sucessfull. I also receive the mail that a folder / file was shared with me but the second mail, with the password information, i dont receive.

In the administration i enabled the option that the password is send by mail.

I tested it with two different recipients.

Maybe its something wrong with my smtp configuraton but its strange that all other mails getting through.

It would be great if someone can help me with this problem.

My configuration:

Nextcloud version: 12
Operating system and version: Ubuntu 16.04
Apache or nginx version : Apache 2.4.18
PHP version : 7.0
Is this the first time you’ve seen this error?: yes

The output of your Nextcloud log in Admin > Logging: There is no information in this log

Have you set it to force sending passwords with email in the sharing settings?

Hi enoch85,

Yes this option is enabled and I activated the debugging log and here is entry too that a mail with the password was sent.

I sent my mails with smtp from another mailbox. this mailbox is not hosted on my nextcloud server. could this be a problem?

If the test email works when configuring it all under additional settings in admin, it should work.
If this is a home server and you’re using local smtp (like postfix), check those logs.

Sounds like this: NC12 File Email Share Error
Patch manually or wait for the 12.0.1 update :slight_smile:

And by the way you probably won’t have any luck finding anything in the logs, either Nextcloud or Apache. In my case I noticed the error pop up right after it failed to send the password email, based on the error message my mail provider gave.

Thanks linucksrox,
looks like my problem - i will try the manual patch. I’m not sure how to do this but i asked this in the linked topic.

EDIT: Problem solved