"Share Link" and "Enable" checkbox missing under local accounts, present in ldap accounts

sharing

#1

Nextcloud version 14.0.4
Operating system and version Ubuntu LTS 18.04.1
Apache 2.4.29:
PHP version 7.2
Group Folders is enabled. Disabling Group folders does not fix the issue below.

The issue you are facing:

When logging in as the local admin account, after clicking the icon to share a folder, I’m presented with a place to type in a user or email address. However, the Share Link Icon, text, and Enable checkbox are missing. I can type in a user or email address in the text box and click the arrow to apply the sharing or send the email, but cannot assign any permissions at all to the share. (such as file drop)

If I do share a folder by typing another user into the text box and share it. I am then unable to stop sharing the folder, as there is no enable checkbox next to the listed user to uncheck.

I created a second local user and the same behavior persists whether admin or not.

When I login as a regular ldap user all of the sharing options are available.
When I promote a regular ldap user to admin, all of the sharing options are available.

I want to create shared folders via the local admin account per the manual, but am unable to do so.

Thanks for any help


#2

As usual, right after confirming 100 times this was an issue I’ve figured it out. The issue is with Chrome. I was using IE and Firefox to login as the ldap users and Chrome as the local users.

The issue was a browser plugin “Disable HTML5 Autoplay”. Just disabling the plugin for your nextcloud site does not work. You must disable it for the site, then shut chrome down and ensure all chrome.exes are killed. Relaunch, now the sharing link and enable checkbox will show up.

Edit: I’ve also discovered Ad Block Plus can cause issues with the Sharing Link and enable checkbox. Disabling it for the site fixes the issue for me.