Share files doesn't work

AFter upgrading to NC 15.02, the sharefiles API doesn’t work has shown in the screenshot

When I click on the logo “sharing”, nothing happens, and there is no sharing.

I also wonder about this. I can no longer generate a link to share a file with non-Nextcloud users

I think your expectation is Share files via Link.
Did you check you setup under https://YOURDOMAIN/index.php/settings/admin/sharing ? It could be that sharing is disabled by admin.

Otherwise you have to enter User Name with whom you would like to share your files.

Sharing via link is not disabled in my case

Do not really know then. Have 15.02 since a few weeks and it works good.
Are you using any external share provider?

No, nothing appear or happens when I click on the icon “share” on the right as shown in the picture,

Just to make it clear, it looks like solved here: No share icon displayed in files app
Just run sudo -u www-data php occ maintenance:repair under your nextcloud installation.

@gas85 That solution does not work (I tried it with no effect). I would point out that this issue is different from the one posted in the other thread. In that thread the share icon was missing (most likely a bad cache hit), but it is not clear that the actual functionality of sharing was affected. What has been reported in this thread (and what I am also experiencing) is that the ability to share via link is not working.

Unable to generate a public share link from the WebUI (option not available in UI)
Unable to generate a public share link from the Android app (times out)

nextcloud v15.0.2
sharing is enabled
sharing via link is enabled

Attempted solutions (none resolved the issue):
running occ maintenance:repair
disabling and re-enabling the “allow users to share via link” settings
disabling and re-enabling the “allow apps to use the Share API” setting
disabling all share related apps
disabling all apps

Sorry for splitting this topic, I have replayed here that it could be misconfiguration.

You can open a ticket in github and developers of NC will have a look on:

After updating to 15.0.4 sharing files via the share icon is working again :slight_smile:

1 Like