Severe issue with External S3 storage

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

Nextcloud version 19.0.0:
Operating system and version Ubuntu 18.04.4 LTS:
Apache or nginx version Apache:
PHP version 7.3.18:

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 18.0.2):
Operating system and version (eg, Ubuntu 20.04):
Apache or nginx version (eg, Apache 2.4.25):
PHP version (eg, 7.1):

The issue you are facing:

Is this the first time you’ve seen this error? (Y/N):

Steps to replicate it:

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):


The output of your Apache/nginx/system log in /var/log/____:



My server updated (snap) itself this morning and since then I do not have access anymore to my S3 buckets from Wasabi.

[PHP] Error: Declaration of OC\Files\ObjectStore\S3Signature::presign(Psr\Http\Message\RequestInterface $request, Aws\Credentials\CredentialsInterface $credentials, $expires) must be compatible with Aws\Signature\SignatureInterface::presign(Psr\Http\Message\RequestInterface $request, Aws\Credentials\CredentialsInterface $credentials, $expires, array $options = Array) at /snap/nextcloud/21796/htdocs/lib/private/Files/ObjectStore/S3Signature.php#36

This issue seems to be the cause:

Since that is reported 3 weeks ago, but in meantime it is not solved.

I can´t change the S3Signature.php since it is read-only.

Looks like “$options = []” needs be added ?

Since Wasabi buckets are our main storage, it is completely not usable now :frowning:

Any suggestions?

kinds regards


I continued my search and found out something changed in the External storage S3.
The region has to be filled in, if not it doesn´t work!
This behaviour came up after the update from 18 to 19.
So got it solved by myself now, sharing the screenshot:

1 Like