Setting up talk

i install talk app on my nextcloud server, then i install nextcloudtalk app on my android, logged in. then i try to call to contact from laptop to android, i see notification that i have a call, open app in android but cannot connect. What is the problem?

so, i try to connect 2 phones to my server via local net and then call, and it works it very good.
Now i think i need caturn or some thing like this. But i do not know how to gonfig it. is any body did it?

Install coturn via apt. Then edit /etc/turnserver.conf (or /etc/coturn/…conf?) that following values match:

listening-port=8443
fingerprint
lt-cred-mech
use-auth-secret
static-auth-secret=<random hex number>
realm=<your.domain.org>
total-quota=100
bps-capacity=0
stale-nonce
cert=/path/to/your/cert.pem
pkey=/path/to/your/privkey.pem
log-file=/var/log/coturn/turn.log
no-loopback-peers
no-multicast-peers

service coturn restart

The static auth secret and listening port need to be set then within nextcloud talk settings.

my.domain what is it? for example my nextcloud path is mydomain.org/cloud what should i use full path or only mydomain.org?

Just use the domain itself without sub path.

doesn’t work, i see incoming call? try to connect and see only black window with name of caller and little window with my face )))))

Did you open/forward the related coturn port in your router to server? In case please provide your coturn config file and what you set in Nextcloud talk settings page.

thank you very much, setup coturn one more time and now it works excellent

I am having similar issues.

Did you open/forward the related coturn port in your router to server?

What needs to be opened in the local (client side) router?