# Service Unavailable Error 503

**URL:** <https://help.nextcloud.com/t/service-unavailable-error-503/36560>\
**Category:** 📦 Appliances (Docker, Snappy, VM, NCP, AIO)\
**Tags:** ncp\
**Created:** [September 10, 2018, 10:55am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560 "2018-09-10T10:55:15Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 10, 2018, 10:55am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/1 "2018-09-10T10:55:16Z")

</div>

hi therei need support for the issue that i’m facing after update my ncp to last release.  
The issues comes when i try to access ncp through webclient, i’m receiving error Service Unavailable, Error 503.

Here setup and logs:

> version: root@rock64:~# ncp-update  
> Downloading updates  
> Performing updates  
> Installing nc-restore  
> Installing nc-backup  
> NextCloudPi updated to version v0.59.0

here ncp-report

[https://pastebin.com/Wi5q4wg7](https://pastebin.com/Wi5q4wg7)

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 11, 2018, 1:33pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/2 "2018-09-11T13:33:13Z")

</div>

any help please!!

---

<div class="post-metadata">

**Author:** ![nachoparker](https://help.nextcloud.com/user_avatar/help.nextcloud.com/nachoparker/32/2975_2.png) [@nachoparker](https://help.nextcloud.com/u/nachoparker)\
**Post date:** [September 12, 2018, 12:23am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/3 "2018-09-12T00:23:21Z")

</div>

how did this happen? you seem to be missing `config.php`. What are the exact steps that lead to this situation?

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 12, 2018, 2:40pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/4 "2018-09-12T14:40:13Z")

</div>

i just updated NCP from web-client and it was sucessfully. the issues has come after power off in my home…

I have checked into NCP that seem there is a file called config.php into this path:

> root@rock64:/var/www/nextcloud/config# ls -la  
> total 64  
> drwxr-x— 2 www-data www-data 4096 Sep 12 04:05 .  
> drwxr-x— 14 www-data www-data 4096 Sep 12 04:05 …  
> -rw-r----- 1 www-data www-data 1446 Sep 12 04:05 config.php  
> -rw-r–r-- 1 www-data www-data 48040 Sep 4 20:02 config.sample.php  
> -rw-r–r-- 1 www-data www-data 264 Sep 4 20:02 .htaccess

and listing file config.php;

> root@rock64:/var/www/nextcloud/config# cat config.php  
> 127.0.0.1 localhost rock64  
> 192.168.1.207 [mydomain-ncp.domain.org](http://mydomain-ncp.domain.org)  
> ::1 localhost rock64 ip6-localhost ip6-loopback  
> fe00::0 ip6-localnet  
> ff00::0 ip6-mcastprefix  
> ff02::1 ip6-allnodes  
> ff02::2 ip6-allrouters

thanks @nachoparker for your support!

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 17, 2018, 11:24am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/5 "2018-09-17T11:24:49Z")

</div>

@nachoparker any idea…?

---

<div class="post-metadata">

**Author:** ![nachoparker](https://help.nextcloud.com/user_avatar/help.nextcloud.com/nachoparker/32/2975_2.png) [@nachoparker](https://help.nextcloud.com/u/nachoparker)\
**Post date:** [September 18, 2018, 12:54am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/6 "2018-09-18T00:54:23Z")

</div>

how did you poweroff? did you just disconnect the raspi?

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 18, 2018, 3:00pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/7 "2018-09-18T15:00:47Z")

</div>

@nachoparker , cutt-off of electricity due maintenance works of electric supplier company, nothing special from my side… :-/

here message of website ncp;

> The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

I have tried to execute:

sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --off

but seem it doesn’t works:

> takezo@rock64:~$ sudo -u www-data php /var/www/nextcloud/occ maintenance:mode --off  
> [sudo] password for takezo:  
> 127.0.0.1 localhost rock64  
> 192.168.1.207 [domainncp.dnsdomain.org](http://domainncp.dnsdomain.org)  
> ::1 localhost rock64 ip6-localhost ip6-loopback  
> fe00::0 ip6-localnet  
> ff00::0 ip6-mcastprefix  
> ff02::1 ip6-allnodes  
> ff02::2 ip6-allrouters  
> Nextcloud is not installed - only a limited number of commands are available
> 
> [Symfony\Component\Console\Exception\CommandNotFoundException]  
> Command “maintenance:mode” is not defined.  
> Did you mean this?  
> maintenance:install

---

<div class="post-metadata">

**Author:** ![nachoparker](https://help.nextcloud.com/user_avatar/help.nextcloud.com/nachoparker/32/2975_2.png) [@nachoparker](https://help.nextcloud.com/u/nachoparker)\
**Post date:** [September 19, 2018, 12:12am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/8 "2018-09-19T00:12:46Z")

</div>

Powercut… that might corrupt your SD card. Try to run `fsck` or similar

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 19, 2018, 9:43am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/9 "2018-09-19T09:43:20Z")

</div>

> [@nachoparker](#):
>
> `fsck`

@nachoparker seem that storage and sdcard are ok.  
i’m intrigued about error message :

> The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

could i reinstall NCP without lost info: data files users and setup done …?

---

<div class="post-metadata">

**Author:** ![nachoparker](https://help.nextcloud.com/user_avatar/help.nextcloud.com/nachoparker/32/2975_2.png) [@nachoparker](https://help.nextcloud.com/u/nachoparker)\
**Post date:** [September 19, 2018, 11:47pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/10 "2018-09-19T23:47:00Z")

</div>

if you have a backup, no problem

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 20, 2018, 11:33am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/11 "2018-09-20T11:33:13Z")

</div>

backup… backup… nope…!  
lets go to the first point, is there anything that i can do to find where and why im getting this error…? (where i can find the problem or missing file…)

thanks @nachoparker for your support?!

---

<div class="post-metadata">

**Author:** ![nachoparker](https://help.nextcloud.com/user_avatar/help.nextcloud.com/nachoparker/32/2975_2.png) [@nachoparker](https://help.nextcloud.com/u/nachoparker)\
**Post date:** [September 20, 2018, 11:29pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/12 "2018-09-20T23:29:08Z")

</div>

Your `ncp-report` output is no longer available… I don’t remember your case

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 21, 2018, 1:56pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/13 "2018-09-21T13:56:07Z")

</div>

> [@nachoparker](#):
>
> `ncp-report`

hi @nachoparker here you have ncp-report output:

[https://pastebin.com/68UbNWWC](https://pastebin.com/68UbNWWC)

---

<div class="post-metadata">

**Author:** ![nachoparker](https://help.nextcloud.com/user_avatar/help.nextcloud.com/nachoparker/32/2975_2.png) [@nachoparker](https://help.nextcloud.com/u/nachoparker)\
**Post date:** [September 22, 2018, 2:12pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/14 "2018-09-22T14:12:32Z")

</div>

Your `config.php` is empty perhaps? in any case, if you have no backups just backup your data and database manually, then run `nc-init` (or reinstall), then restore your manual backup.

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 26, 2018, 12:04pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/15 "2018-09-26T12:04:57Z")

</div>

@nachoparker I have executed ncp-backup command and seem that is not working. here you have output:

> Launching nc-backup  
> /usr/local/bin/ncp-backup: line 13: warning: command substitution: ignored null byte in input
> 
> [Symfony\Component\Console\Exception\CommandNotFoundException]  
> There are no commands defined in the “config:system” namespace.
> 
> Error reading data directory. Is NextCloud running and configured?  
> Done. Press any key…

any clue?

---

<div class="post-metadata">

**Author:** ![nachoparker](https://help.nextcloud.com/user_avatar/help.nextcloud.com/nachoparker/32/2975_2.png) [@nachoparker](https://help.nextcloud.com/u/nachoparker)\
**Post date:** [September 26, 2018, 11:25pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/16 "2018-09-26T23:25:07Z")

</div>

Your config.php is likely empty. You need to backup manually

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 27, 2018, 9:43am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/17 "2018-09-27T09:43:10Z")

</div>

hi @nachoparker ok, done!  
trying to execute new installation of NCP from scrash I’m now getting following errors:

> root@rock64:/media/DataMedia/cloud# curl -sSL [https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh](https://raw.githubusercontent.com/nextcloud/nextcloudpi/master/install.sh) | bash
> 
> > > > WARNING: existing mysqld configuration will be changed \<\<\<  
> > > > Getting build code…  
> > > > Hit:1 [http://security.debian.org](http://security.debian.org) stretch/updates InRelease  
> > > > Hit:3 [http://apt.armbian.com](http://apt.armbian.com) stretch InRelease  
> > > > Ign:2 [Index of /debian](http://cdn-fastly.deb.debian.org/debian) stretch InRelease  
> > > > Hit:4 [Index of /debian](http://cdn-fastly.deb.debian.org/debian) stretch-updates InRelease  
> > > > Hit:5 [Index of /debian](http://cdn-fastly.deb.debian.org/debian) stretch-backports InRelease  
> > > > Hit:6 [Index of /debian](http://cdn-fastly.deb.debian.org/debian) stretch Release  
> > > > Reading package lists… Done  
> > > > Reading package lists… Done  
> > > > Building dependency tree  
> > > > Reading state information… Done  
> > > > ca-certificates is already the newest version (20161130+nmu1+deb9u1).  
> > > > sudo is already the newest version (1.8.19p1-2.1).  
> > > > wget is already the newest version (1.18-5+deb9u2).  
> > > > 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.  
> > > > 1 not fully installed or removed.  
> > > > After this operation, 0 B of additional disk space will be used.  
> > > > Setting up php7.0-fpm (7.0.30-0+deb9u1) …  
> > > > Job for php7.0-fpm.service failed because the control process exited with error code.  
> > > > See “systemctl status php7.0-fpm.service” and “journalctl -xe” for details.  
> > > > invoke-rc.d: initscript php7.0-fpm, action “restart” failed.  
> > > > â— php7.0-fpm.service - The PHP 7.0 FastCGI Process Manager  
> > > > Loaded: loaded (/lib/systemd/system/php7.0-fpm.service; enabled; vendor preset: enabled)  
> > > > Active: failed (Result: exit-code) since Thu 2018-09-27 11:41:10 CEST; 25ms ago  
> > > > Docs: man:php-fpm7.0(8)  
> > > > Process: 4019 ExecStart=/usr/sbin/php-fpm7.0 --nodaemonize --fpm-config /etc/php/7.0/fpm/php-fpm.conf (code=exited, status=78)  
> > > > Main PID: 4019 (code=exited, status=78)
> 
> Sep 27 11:41:09 rock64 systemd[1]: Starting The PHP 7.0 FastCGI Process Manâ€¦r…  
> Sep 27 11:41:09 rock64 php-fpm7.0[4019]: Cannot load Zend OPcache - it was aâ€¦ded  
> Sep 27 11:41:10 rock64 php-fpm7.0[4019]: [27-Sep-2018 11:41:10] ERROR: [/etcâ€¦TRY  
> Sep 27 11:41:10 rock64 php-fpm7.0[4019]: [27-Sep-2018 11:41:10] ERROR: Unablâ€¦e 1  
> Sep 27 11:41:10 rock64 php-fpm7.0[4019]: [27-Sep-2018 11:41:10] ERROR: faileâ€¦nf’  
> Sep 27 11:41:10 rock64 php-fpm7.0[4019]: [27-Sep-2018 11:41:10] ERROR: FPM iâ€¦led  
> Sep 27 11:41:10 rock64 systemd[1]: php7.0-fpm.service: Main process exited,â€¦/n/a  
> Sep 27 11:41:10 rock64 systemd[1]: Failed to start The PHP 7.0 FastCGI Procâ€¦ger.  
> Sep 27 11:41:10 rock64 systemd[1]: php7.0-fpm.service: Unit entered failed â€¦ate.  
> Sep 27 11:41:10 rock64 systemd[1]: php7.0-fpm.service: Failed with result ‘â€¦de’.  
> Hint: Some lines were ellipsized, use -l to show in full.  
> dpkg: error processing package php7.0-fpm (–configure):  
> subprocess installed post-installation script returned error exit status 1  
> Errors were encountered while processing:  
> php7.0-fpm  
> needrestart is being skipped since dpkg has failed  
> E: Sub-process /usr/bin/dpkg returned an error code (1)

---

<div class="post-metadata">

**Author:** ![nachoparker](https://help.nextcloud.com/user_avatar/help.nextcloud.com/nachoparker/32/2975_2.png) [@nachoparker](https://help.nextcloud.com/u/nachoparker)\
**Post date:** [September 27, 2018, 1:37pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/18 "2018-09-27T13:37:04Z")

</div>

awesome, save your backup in your computer, and flash the latest SD card image.

Then, restore your backup

---

<div class="post-metadata">

**Author:** ![takezo](https://help.nextcloud.com/user_avatar/help.nextcloud.com/takezo/32/39331_2.png) [@takezo](https://help.nextcloud.com/u/takezo)\
**Post date:** [September 27, 2018, 5:54pm UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/19 "2018-09-27T17:54:41Z")

</div>

😥

---

<div class="post-metadata">

**Author:** ![wwe](https://help.nextcloud.com/user_avatar/help.nextcloud.com/wwe/32/72963_2.png) [@wwe](https://help.nextcloud.com/u/wwe)\
**Post date:** [December 4, 2024, 7:41am UTC](https://help.nextcloud.com/t/service-unavailable-error-503/36560/20 "2024-12-04T07:41:04Z")

</div>



[Next page](https://help.nextcloud.com/t/service-unavailable-error-503/36560.md?page=2)
