Server not responding on mobile network (UMTS/4G...)

Hi,
i am using NextCloudPi and its working since a year, but since a month I suddenly can not connect to the server with the mobile app from mobile network.
When I am on Wifi => everything works. Mobile Network => Server not responding.
Desktop clients are working perfectly.

Does someone know why this is happening?
Fairphone 3, Android 10, App Version 3.13.1.
I Would give you more informations, but at the Moment I dont know which :slight_smile:

  1. You should try to access your server over the internet from a PC with a normal web browser, to check if it is still reachable.
  2. You should make sure that your server is reachable over IPv4/IPv6 correctly.
  3. You should make sure that your router is not connecting to the internet using a DSL light connection.
1 Like

Hey thanks for your answer!

  1. is reachable
  2. ah I think there is the problem with IPv6: Destination unreachable: Administratively prohibited
  3. is not the case

What do I have to do to geht IPv6 working? thanks in advance!

Unfortunately a one-fits-all answer on this question doesn’t exist, because a solution multiple things. Sometimes it helps to deactivate IPv6 on your router and server so that only an IPv4 is returned on a DNS lookup. sometimes it is necessary to explicitly activate IPv6 on your internet router if you really want to use IPv6, sometimes a tunnel connection need to be established etc., etc.

Without any information on your internet connection, provider, network layout, your domain, etc., etc. it won’t be possible to recommend anything specific to you.

I understand.
I use a Fritzbox 7560, IPv6 is activated and ping6 also. Port 80, 443 are open.
Also I use an Rapsberry Pi with NextcloudPi its directly connected over LAN to the Fritzbox.
My dns provider is Duckdns.org. Provider is 1&1

ifconfig of the rapsberry:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.178.50  netmask 255.255.255.0  broadcast 192.168.178.255
        inet6 fe80::8916:7c1:95db:9221  prefixlen 64  scopeid 0x20<link>
        inet6 2003:c8:3721:7800:abdc:4fbb:1cbd:8034  prefixlen 64  scopeid 0x0<global>
        ether dc:a6:32:1b:2b:1c  txqueuelen 1000  (Ethernet)
        RX packets 351430  bytes 90857305 (86.6 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 234298  bytes 136111739 (129.8 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Sorry i am pretty lost here, tried to find some answers, but i am not good enough with this to fully understand it. Do you need some other informations?

Okay switched my Fritzbox to: “Native IPv6-Anbindung verwenden” (use native IPv6).
Now I can ping the IPv6 Address but the app is still not connecting over “mobile Network”

Can you access Nextcloud using the web browser on your mobile phone?

With WIFI: yes, mobile network: no.
Tried it at the moment with another phone and… yes there it is working (with mobile network).
So its a Device specific problem

You should also check the mobile network which is used by the phones. It would be possible that one network provides IPv6 addresses and the other one uses IPv4 ones.

Thanks for your help, I am bit confused right now. It seems like my mobile phone provider blocked the site, but I am not sure at all.
Because IP4 and 6 do not work on “mobile network” (is this the right term in english?) but both work on wifi (checked it). I entered directly the IP Addresses from duckdns (sure nextcloud will block, because of the hostname). On mobile it behaves like the site doesnt exist at all.

did you try “a network tool” on your mobile to check your connection?

i just search the playstore (android) for “traceroute” and different tools listet. (incl. traceroute, ping, portmap)

Good Idea!
Ping is working on IP4 and 6, DNS is also available.
But when I search for ports on mobile network: all are closed. But why is this only on mobile?

Okay I think I found the Problem, has something todo with the fritzbox. Man this is a long story :smiley:
Thanks for helping me. I try to figure it out and when I found it, I will post it!

1 Like

So Guys, I tried the whole evening and a good part of today to find the reason for this. I know this is probably not in the scope of this forum, but maybe you can help me.
So on my FritzBox and on DuckDns the IP and Ipv6 are the same. When I add port forwarding (80 &443), the IP Address of IPv6 are not matching. Do I have to change something on the PI or is this a Fritzbox problem?
Duckdns:
Bildschirmfoto-1
Fritzbox connection monitor:
Bildschirmfoto-2
Fritzbox Port forwarding (here you see the IPv6 is the one of the Raspberry and not of the Fritzbox, and I know the ID is not right at the moment I took the pic)


Just a check for IPv6 Ports.

Hi @Bauerbyter,
does your IPv6 in Duckdns really point to the IPv6 address of your server? IPv4 is here different to IPv6:
IPv4: Your FritzBox forwards a special port to your server.
IPv6: Your local server has it’s own IPv6 address and your FritzBox only filters the access to it.

1 Like

Thanks! yes this was the problem I didnt get. But I fixed it now (and learned a lot, thanks to all!)
After I understood the problem, I just executed this script: https://github.com/gtwy/IPv6forDuckDNS
Very good way to add IPV6 of the PI to duckdns!

2 Likes