Server has no working Internet connection

I migrated and upgraded an owncloud 9.1 Installation to Nextcloud 13 (->10-11-12 and now 13.0.2). In all Versions i had the problem with:

  • This server has no working Internet connection: Multiple endpoints could not be reached. This means that some of the features like mounting external storage, notifications about updates or installation of third-party apps will not work. Accessing files remotely and sending of notification emails might not work, either. Establish a connection from this server to the Internet to enjoy all features.
  • The /updater always worked, so I could make upgrades on this way
  • The server has a working internet connection, the firewall has no hits
  • It’s an Ubuntu 16.04 LTS

I have read many hints here and on the web, but couldn’t solve the problem…

As I can’t reinstall any Third party app (calendar, contacts) now, it is an important issue

How can I get a working config?

Thanks in advance


We need a lot more information here. Please post your config file without the passwords. Anything in the nextcloud.log? apache or nginx logs? Something about your network settings would be helpful too i guess.


After search with my php colleague I found the solution:

In my configuration I had the following directives:
‘proxy’ => ‘’,
‘proxyuserpwd’ => ‘’,

So for others with this problem: An empty proxy configuration results in:
ion_check GuzzleHttp\Exception\RequestException: cURL error 56: Proxy CONNECT aborted

This Thread can be closed…

I have the same issue… my config.php:

$CONFIG = array (
  'instanceid' => 'INSTANCEID',
  'passwordsalt' => 'PASSWORDSALT',
  'secret' => 'SECRETHERE',
  'trusted_domains' =>
  array (
    0 => 'MYINTERNALIP',
    1 => 'MYFQDN',
  'datadirectory' => '/var/www/nextcloud/data',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => 'MYOVERWRITEURL',
  'dbname' => 'nextcloud',
  'dbhost' => 'localhost:3306',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'MYDBNAME',
  'dbpassword' => 'MYDBPASSWORD',
  'mysql.utf8mb4' => true,
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'mail_smtpmode' => 'smtp',
  'mail_smtpsecure' => 'ssl',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'MYGMAILADDRESS',
  'mail_domain' => '',
  'mail_smtphost' => '',
  'mail_smtpport' => '465',
  'mail_smtpauth' => 1,
  'mail_smtpname' => 'MYGMAILADDRESS',
  'mail_smtppassword' => 'MYPASSWORD',
  'updater.secret' => 'MYUPDATESECRET',
  'app_install_overwrite' =>
  array (
    0 => 'groupfolders',
    1 => 'spreed',
  'mail_smtpauthtype' => 'LOGIN',

I will state that my setup is not https.