Server error for the web interface during installation


I’m trying to install Nextcloud on an Olimex A64-OLinuXino, Allwinner A64.

I boot on the latest version of armbian available on their website.
I installed the PCN package directly from armbian-config but I can’t connect from the web interface with the server IP address.

I have opened ports 80 and 443 of my Modem but same result: “server error”.

Could I get a hand, please?


J’essaie d’installer Nextcloud sur un Olimex A64-OLinuXino, Allwinner A64.

Je boot sur la derniere version de armbian disponible sur leur site.
J’ai installé le paquet NCP directement depuis armbian-config mais je n’arrive à me connecter depuis l’interface web avec l’adresse IP du serveur.

J’ai ouvert les port 80 et 443 de mon Modem mais même résultat : “erreur du serveur”

pourais je avoir un coup de main s’il vous plait

Check the webserver log.

Which NC version are you using.

Hello @rakekniven,

Here’s the browser message:

"# Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.
Please contact the server administrator at [no address given] to inform them of the time this error occurred, and the actions you performed just before this error.
More information about this error may be available in the server error log. "

I looked at the nextcloud.log file. I can’t copy and paste from Putty but it says:

“message : could not connect to the appstore : cURL error 6 : could not resolve host: (see” “user agent --”“version” :“”

I’ve got another nextcloud server on a yunohost running on the same modem. But I had already tried to replace it on port 80 and 443 but always the same result.


Please ssh into the host and try to ping the appstore and tell us?

Please do that, not the nextcloud.log