Server Error after sending reistration link

Hey there,

my nectcloud 18 runs on a normal webspace and without any bigger problems.

Now, some new users want to registrate, but get this:

Interner Serverfehler
Der Server konnte die Anfrage nicht fertig stellen.
Sollte dies erneut auftreten, sende bitte die nachfolgenden technischen   Einzelheiten an Deinen Server-Administrator.

Weitere Details können im Server-Protokoll gefunden werden.
Technische Details

Entfernte Adresse: xx.xx.xx.xx
Anfragekennung: XrWQgLz@QFnQWSnnOdwopwAAAA8

after sending their emailadress to get an activation link.

I tried my myself and got the link without any problems.
Asked the user to try again - same result.

I look ad the log file, but i dont know wat`s wrong:

{"reqId":"XrWQgLz@QFnQWSnnOdwopwAAAA8","level":3,"time":"2020-05-08T17:01:56+00:00","remoteAddr":"94.134.179.37","user":"--","app":"index","method":"POST","url":"/ncloud/index.php/apps/registration/","message":{"Exception":"Swift_TransportException","Message":"Expected response code 354 but got code \"554\", with message \"554 5.5.1 Error: no valid recipients\r\n\"","Code":554,"Trace":[{"file":"/www/htdocs/w000001/ncloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php","line":341,"function":"assertResponseCode","class":"Swift_Transport_AbstractSmtpTransport","type":"->","args":["554 5.5.1 Error: no valid recipients\r\n",[354]]},{"file":"/www/htdocs/w000001/ncloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/EsmtpTransport.php","line":305,"function":"executeCommand","class":"Swift_Transport_AbstractSmtpTransport","type":"->","args":["DATA\r\n",[354],["name@posteo.de"],false,null]},{"file":"/www/htdocs/w000001/ncloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php","line":390,"function":"executeCommand","class":"Swift_Transport_EsmtpTransport","type":"->","args":["DATA\r\n",[354],["name@posteo.de"]]},{"file":"/www/htdocs/w000001/ncloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php","line":497,"function":"doDataCommand","class":"Swift_Transport_AbstractSmtpTransport","type":"->","args":[["name@posteo.de"]]},{"file":"/www/htdocs/w000001/ncloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php","line":516,"function":"doMailTransaction","class":"Swift_Transport_AbstractSmtpTransport","type":"->","args":[{"__class__":"Swift_Message"},"admin@domain.de",["name@posteo.de"],["name@posteo.de"]]},{"file":"/www/htdocs/w000001/ncloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php","line":206,"function":"sendTo","class":"Swift_Transport_AbstractSmtpTransport","type":"->","args":[{"__class__":"Swift_Message"},"admin@domain.de",{"name@posteo.de":null},["name@posteo.de"]]},{"file":"/www/htdocs/w000001/ncloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Mailer.php","line":71,"function":"send","class":"Swift_Transport_AbstractSmtpTransport","type":"->","args":[{"__class__":"Swift_Message"},["name@posteo.de"]]},{"file":"/www/htdocs/w000001/ncloud/lib/private/Mail/Mailer.php","line":192,"function":"send","class":"Swift_Mailer","type":"->","args":[{"__class__":"Swift_Message"},["name@posteo.de"]]},{"file":"/www/htdocs/w000001/ncloud/apps/registration/service/mailservice.php","line":101,"function":"send","class":"OC\\Mail\\Mailer","type":"->","args":[{"__class__":"OC\\Mail\\Message"}]},{"file":"/www/htdocs/w000001/ncloud/apps/registration/controller/registercontroller.php","line":90,"function":"sendTokenByMail","class":"OCA\\Registration\\Service\\MailService","type":"->","args":[{"id":11,"__class__":"OCA\\Registration\\Db\\Registration"}]},{"file":"/www/htdocs/w000001/ncloud/lib/private/AppFramework/Http/Dispatcher.php","line":170,"function":"validateEmail","class":"OCA\\Registration\\Controller\\RegisterController","type":"->","args":["name@posteo.de"]},{"file":"/www/htdocs/w000001/ncloud/lib/private/AppFramework/Http/Dispatcher.php","line":99,"function":"executeController","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[{"__class__":"OCA\\Registration\\Controller\\RegisterController"},"validateEmail"]},{"file":"/www/htdocs/w000001/ncloud/lib/private/AppFramework/App.php","line":125,"function":"dispatch","class":"OC\\AppFramework\\Http\\Dispatcher","type":"->","args":[{"__class__":"OCA\\Registration\\Controller\\RegisterController"},"validateEmail"]},{"file":"/www/htdocs/w000001/ncloud/lib/private/AppFramework/Routing/RouteActionHandler.php","line":47,"function":"main","class":"OC\\AppFramework\\App","type":"::","args":["OCA\\Registration\\Controller\\RegisterController","validateEmail",{"__class__":"OC\\AppFramework\\DependencyInjection\\DIContainer"},{"_route":"registration.register.validateEmail"}]},{"function":"__invoke","class":"OC\\AppFramework\\Routing\\RouteActionHandler","type":"->","args":[{"_route":"registration.register.validateEmail"}]},{"file":"/www/htdocs/w000001/ncloud/lib/private/Route/Router.php","line":299,"function":"call_user_func","args":[{"__class__":"OC\\AppFramework\\Routing\\RouteActionHandler"},{"_route":"registration.register.validateEmail"}]},{"file":"/www/htdocs/w000001/ncloud/lib/base.php","line":1008,"function":"match","class":"OC\\Route\\Router","type":"->","args":["/apps/registration/"]},{"file":"/www/htdocs/w000001/ncloud/index.php","line":38,"function":"handleRequest","class":"OC","type":"::","args":[]}],"File":"/www/htdocs/w000001/ncloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php","Line":457,"CustomMessage":"--"},"userAgent":"Mozilla/5.0 (X11; Linux x86_64; rv:68.0) Gecko/20100101 Firefox/68.0","version":"18.0.4.2"}

Has anyone a solution for this problem?

Thanks a lot :slight_smile:

Unfortunately this question cannot be answered without knowing how you’ve configured the email server settings in Nextcloud. The send email seems not to be accepted by the remote SMTP server due to an invalid recipient or a missing authentication.

Please use the search function of this forum or ask aunt G. for further information. Here are some other threads covering that kind of problem:



Hi jed,
thanks for your answer, it comes pretty close to the solution. Somewhere I have a robust one with my SMTP server. After switching to “sendmail”, the other users can now also register.
They couldn’t because they had given an email address that did not come from “my” mail server. Therefore I could not reproduce the error with my own email address.

1 Like