Sender name and avatar"?"

Good day, when synchronizing with the mailbox via imap, everything goes well, but the names in the inbox folder are displayed as “?”, And the avatar is also like “?”.
There are several errors in the log “”
Error PHP rtrim () expects parameter 1 to be string, array given at /var/www/nextcloud/apps/mail/vendor/cerdic/css-tidy/class.csstidy_print.php#346
2020-05-10T22: 42: 33 + 0300
Error PHP Invalid argument supplied for foreach () at /var/www/nextcloud/apps/mail/vendor/ezyang/htmlpurifier/library/HTMLPurifier/Filter/ExtractStyleBlocks.php#149
2020-05-10T22: 42: 33 + 0300
Error PHP rtrim () expects parameter 1 to be string, array given at /var/www/nextcloud/apps/mail/vendor/cerdic/css-tidy/class.csstidy_print.php#346
2020-05-10T22: 42: 18 + 0300
Error PHP Invalid argument supplied for foreach () at /var/www/nextcloud/apps/mail/vendor/ezyang/htmlpurifier/library/HTMLPurifier/Filter/ExtractStyleBlocks.php#149
2020-05-10T22: 42: 18 + 0300
Error PHP rtrim () expects parameter 1 to be string, array given at /var/www/nextcloud/apps/mail/vendor/cerdic/css-tidy/class.csstidy_print.php#346
2020-05-10T22: 42: 15 + 0300
Error PHP Invalid argument supplied for foreach () at /var/www/nextcloud/apps/mail/vendor/ezyang/htmlpurifier/library/HTMLPurifier/Filter/ExtractStyleBlocks.php#149
2020-05-10T22: 42: 15 + 0300

Can anyone explain what to do? or what’s wrong.
Centos 7 / nginx / php-fpm
mail.ru mail server

Sounds like the (initial) sync did not insert recipients for the fetched messages. Do you have any entries in oc_mail_recipients? Is it one or all messages that have the ??

Hello, it goes like this:
if I synchronize mail automatically, then all the old letters in inbox do not appear at all, but in the other folders the old letters are displayed normally. If a new letter arrives, then it is displayed correctly.
Option 2, if I manually configure mail by IMAP and SMTP, then all the old letters in the Inbox folder are displayed “?”, New ones are displayed normally, in other folders the old letters also look normal.

if you need logs, say lay out. I can even give ssh. The server is in the launch phase.

in the nextcloud.log:
{“reqId”:“SYzAt4rbPEEk0PbO7uw7”,“level”:3,“time”:“2020-05-13T15:11:21+00:00”,“remoteAddr”:“192.168.1.1”,“user”:“alex”,“app”:“ocs_api”,“method”:“POST”,“url”:"/ocs/v2.php/cloud/users",“message”:{“Exception”:“Swift_TransportException”,“Message”:“Connection could not be established with host 127.0.0.1 :stream_socket_client(): unable to connect to 127.0.0.1:25 (Connection refused)”,“Code”:0,“Trace”:[{“function”:"{closure}",“class”:“Swift_Transport_StreamBuffer”,“type”:"->",“args”:["*** sensitive parameters replaced "]},{“file”:"/var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php",“line”:272,“function”:“stream_socket_client”,“args”:[“127.0.0.1:25”,111,“Connection refused”,10,4,null]},{“file”:"/var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/StreamBuffer.php",“line”:58,“function”:“establishSocketConnection”,“class”:“Swift_Transport_StreamBuffer”,“type”:"->",“args”:[]},{“file”:"/var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Transport/AbstractSmtpTransport.php",“line”:143,“function”:“initialize”,“class”:“Swift_Transport_StreamBuffer”,“type”:"->",“args”:[{“protocol”:"",“host”:“127.0.0.1”,“port”:25,“timeout”:10,“blocking”:1,“tls”:false,“type”:1,“stream_context_options”:" sensitive parameter replaced "}]},{“file”:"/var/www/nextcloud/3rdparty/swiftmailer/swiftmailer/lib/classes/Swift/Mailer.php",“line”:65,“function”:“start”,“class”:“Swift_Transport_AbstractSmtpTransport”,“type”:"->",“args”:[]},{“file”:"/var/www/nextcloud/lib/private/Mail/Mailer.php",“line”:192,“function”:“send”,“class”:“Swift_Mailer”,“type”:"->",“args”:[{“class”:“Swift_Message”}," sensitive parameter replaced ***"]},{“file”:"/var/www/nextcloud/apps/settings/lib/Mailer/NewUserMailHelper.php",“line”:175,“function”:“send”,“class”:“OC\Mail\Mailer”,“type”:"->",“args”:[{“class”:“OC\Mail\Message”}]},{“file”:"/var/www/nextcloud/apps/provisioning_api/lib/Controller/UsersController.php"

after loaded old letters, if i open some letter in nextcloud.log:
{“reqId”:“KU9cBBK5E9agKSZrtfEf”,“level”:3,“time”:“2020-05-13T17:00:02+00:00”,“remoteAddr”:“192.168.1.1”,“user”:“alex”,“app”:“PHP”,“method”:“GET”,“url”:"/core/preview?fileId=94903&c=651b01ce58cf2d78ecc9fb2cc98743f8&x=250&y=250&forceIcon=0",“message”:“imagettftext(): Problem doing text layout at /var/www/nextcloud/lib/private/Preview/TXT.php#91”,“userAgent”:“Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:76.0) Gecko/20100101 Firefox/76.0”,“version”:“18.0.4.2”}

if I understand correctly, the last error is that there are not enough fonts. I examined mail.ru objects in a web browser, there are fonts, arial, tahoma, verdana. Nextcloud has these fonts only in onlyoffice. but I don’t know how to add them to the mail client.

I do not see a connection to the missing sender information. You may ignore that for this issue.

I think, after synchronization, it loads from the cache.

Christoph, Can you help me?. I sent a screenshot so that you better understand what is happening

update mail app at the version 1.3.5 and the mail working correctly.