"Select tags to enforce watermarking" list empty

Nextcloud Version: 23.0.3
Operating System Version: Linux 5.13.0-39-generic x86_64

The list area to choose tags for Watermarking is empty. It offers no pop-up list of tags and will not respond when I type something to search for. I’ve tried clearing all my tags, also emptying the tags table in the nextcloud database, and adding new tags. Still no options in this field.

At first I could go into Administration settings for Office and choose any of my tags to enforce Watermarking, with no issue. But now the list is empty. It will not return any results. When I remove all the tags in my instance, it will return the result “List Empty.” But as soon as I add a new tag to the instance, it returns to being unresponsive.

The only thing I can recall doing before this stopped functioning: I deleted one of the chosen tags for watermarking from elsewhere (in the “details” view on a file in the Nextcloud interface.) When I came back to the settings, that field was blank. I believe that was when it stopped working.